[ntp:questions] ntp-4.2.6p5 on Win 7 x64

Nick me at privacy.net
Thu Jul 24 16:41:25 UTC 2014

On Tue, 22 Jul 2014 19:29:01 +0100, David Taylor wrote:

> Nick, I have seen (some time back) NTP run a little wild when the drift
> file is so near the limit.  You aren't overclocking, I suppose?  Anyway,
> try deleting the drift file and letting NTP run for more than an hour.

No overclocking on this machine!  Deleting the drift file fixes it.

> If there's something which is causing your PC to have an incorrect clock
> in Windows, you /may/ be able to compensate using an environment
> variable as described here:
>    http://www.satsignal.eu/ntp/setup.html#broken-clock
> Oh, it looks like you've considered that already, but have you tried

Yes I tried that and it didn't seem to matter what value was set the 
performance got worse.  The jitter is so bad.

> I suppose there's no issue with power-saving, or a spread-spectrum BIOS?

Funny you should say that.  Although all the PM is turned off in the BIOS 
I found a sneaky setting via Control Panel called Power Management, 
Minimum Processor State.  Changing this from 5% to 100% reduced the DPC 
latency dramatically and improved NTP's performance.

Offsets and jitters now in the 10's of ms.

More information about the questions mailing list