[ntp:questions] ntp-4.2.6p5 on Win 7 x64

Nick me at privacy.net
Thu Jul 24 16:44:41 UTC 2014

On Thu, 24 Jul 2014 12:14:21 +0200, Martin Burnicki wrote:

> Have you also tested without -M switch?
I will do.  There are a number of test cases I want to try.

>> What makes ntpd think that the frequency error on Windows is +493?
>  From my experience such frequency error under Windows is simply wrong
> because the time stamps read from the system time provide too much
> jitter.
Yes.  I deleted ntp.drift and the error went down to 125.  Just deleted it
again and it's dropped to -19.

> What's the output of "ntpq -p" in this case? I'm assuming the numbers
> both for jitter and offset are very large, eventually more than 1000 ms.


>> wclkres64 reports that performance counter frequency is 2.734MHz.  The
>> QPC execution time for 1000 calls varies between 26ns and 37ns.
> This should only matter at all if ntpd interpolates the system time
> using APC timer callbacks and QPC calls.
> ntpd-dev should not use interpolation at all if it detects that the
> system time increments in 1 ms steps. If interpolation is *not* used
> then after startup of the NTP service there should be a message in the
> Windows application event log reading "using windows clock directly".

Yes I see that message with the -M switch.

I had a look at the DPC latency which was regularly peaking over 10ms.
Disabled the index service which improved things.  Although all the power
management in the BIOS is disabled I set Power Management, Minimum 
Processor State to 100% and all the DPC delays disappeared.  I also 
updated the BIOS and the motherboard drivers, just in case.

NTP now works a bit better.  Reach gets to 377 and stays there.  Offsets
and jitters are now in the 10's of ms rather than 100's or 1000's.

I know there's more to be had from it because I see offsets and jitters
in the low ms on XP.

More information about the questions mailing list