[ntp:questions] NTP server not reducing polling interval on upstream hosts

William Unruh unruh at invalid.ca
Sat Oct 18 03:53:24 UTC 2014

On 2014-10-18, Phil W Lee <phil at lee-family.me.uk> wrote:
> William Unruh <unruh at invalid.ca> considered Fri, 17 Oct 2014 18:40:55
> +0000 (UTC) the perfect time to write:
>>On 2014-10-17, Phil W Lee <phil at lee-family.me.uk> wrote:
>>> David Taylor <david-taylor at blueyonder.co.uk.invalid> considered Fri,
>>> 17 Oct 2014 07:14:47 +0100 the perfect time to write:
>>>>On 17/10/2014 04:25, Phil W Lee wrote:
>>>>> Can I upgrade by just swapping a newer binary in?
>>>>> I'm not really far enough up the FreeBSD learning curve to work out
>>>>> why I'm getting errors trying to build a newer one from source (I did
>>>>> at least try).
>>>>When updating I follow the instructions here:
>>>>   http://www.satsignal.eu/ntp/FreeBSD-GPS-PPS.htm#update
>>>>The instructions under "Updating NTP to a later version" you need to do 
>>>>just once, so see where they fall over and let us know what the error 
>>>>message is.
>>> I was using the instructions on Ryan Doyle's site for that, since his
>>> setup seems to more closely match mine, he uses bash and doesn't even
>>> mention installing portmaster.
>>> I get to where he says:
>>> "[root at freebsd /usr/ports/net/ntp]# make config install clean"
>>Try just make config
>>so you can see the errors more clearly. Also you should be able to
>>scroll up to see what the errors were. You may not have some
>>developement library installed. 
> Development libraries just to install software?

No. To compile it. 

>>> and the error messages scroll off the screen too fast for me to read
>>> them. It seems to start off with "Unknown modifier 'up-arrow' (the
>>> symbol up arrow, not the text).
>>Do you mean caret-- the symbol above 6 on the US keyboard? (I am not
>>sure where it is on theUK keyboard)
> No, not caret.
> an actual upward pointing arrow, complete with stem, somewhat like
> thee unicode character 2191.

Hm. No idea what that would be. 
Have you tried just doing make config?

>>> This is repeated multiple times, followed by some other errors which
>>> are probably a result of the first errors, iyswim.
>>> I just followed your guide, and got an identical shedload of errors
>>> when trying to install portmaster.
>>> As far as I can see, both methods achieve the same results.
>>>>The later instructions under "Updating the updater - telling portmaster 
>>>>about a newer version" are what I do each time I update to a new release 
>>>>of the development version.  These are under FreeBSD 8.2 but I imagine 
>>>>they would also work under 8.1.  I keep a copy of the current binaries 
>>>>on a remote FTP server in case an upgrade goes wrong.  Essentially 
>>>>that's the files I compiled before in "/usr/local/sbin/ntp*".
>>>>I could put my current version binaries into a Zip file and upload it 
>>>>for you to try, if you like.
>>> I just tried that, with the binaries of ntp-4.2.7p364_2 and
>>> ntp-devel-4.2.7.p411.
>>> Ntp crashed and burned when attempting to start - it looks like they
>>> rely on later libraries, which only a proper install will give me.
>>They should be general libraries. AFAIremember, ntpd does not have
>>libraries of its own.
> They may well be general libraries, but a later version of ntp may
> equally well depend on a later version of the library.
> That's the sort of dependency that an installer checks and fixes (or
> we'd never need installation processes at all).

It could but I do not think so. ntpd uses a pretty basic set of
libraries as I recall. 
What does "crash and burn" mean? Maybe your house was hit by a meteorite
just as you started ntpd:-)
Ie, specifics and error messages and log messages might help figure out
what the problem is. 

>>> I'm glad I'm testing all this in a virtual instance of the real
>>> machine, instead of the real machine itself.
>>Which may of course be part of the problem.
> I doubt it - I only started on all the attempts to upgrade because of
> the problems on the main instance.
> All I'm testing on the virtual is the installation method - the builds
> are identical except that iirc, the real box has SCSI disks instead of
> the virtual one's equally virtual IDE, and of course, they are on
> different IP addresses.

More information about the questions mailing list