[ntp:questions] Use ntp orphan mode to sync time two stand-alone computers

Jason Beach jason.m.beach at gmail.com
Sun Aug 14 01:28:52 UTC 2016


I have two arm-based Linux (ubuntu 14.04) computers, a Jetson TK1 and TX1
that will fly on a multicopter and hence have no internet connection (they
are networked together onboard).  They also do not have RTC's built-in but
I have added a smll external one (https://www.adafruit.com/product/255) to
the Jetston TK1.  The TK1's time gets set on boot from this RTC no problem
(using a `sudo hwclock -s -f /dev/rtc0` in rc.local).  I am trying to get
the TX1 to sync to the TK1's time using ntp.

The TK1's ntp.conf file contains:

    driftfile /var/lib/ntp/ntp.drift

    server 0.us.pool.ntp.org
    server 1.us.pool.ntp.org
    server 2.us.pool.ntp.org
    server 3.us.pool.ntp.org

    tos orphan 5

The TX1's ntp.conf file contains:

    driftfile /var/lib/ntp/ntp.drift

    # Specify one or more NTP servers.

    server 10.20.3.149 iburst prefer

    server 0.ubuntu.pool.ntp.org
    server 1.ubuntu.pool.ntp.org
    server 2.ubuntu.pool.ntp.org
    server 3.ubuntu.pool.ntp.org

where 10.20.3.149 is the IP address of the TK-1. If I run `ntpq -p` I get

         remote           refid      st t when poll reach   delay   offset
 jitter

==============================================================================
     192.168.0.10    .INIT.          16 -    -  512    0    0.000    0.000
  0.000
     192.168.3.149   .INIT.          16 -    -  512    0    0.000    0.000
  0.000

and if I run `ntpdate -dv 10.20.3.149` I get

    12 Aug 12:36:23 ntpdate[2197]: ntpdate 4.2.6p5 at 1.2349-o Thu Feb 11
18:30:14 UTC 2016 (1)
    Looking for host 10.20.3.149 and service ntp
    host found : TK-Astro
    transmit(10.20.3.149)
    receive(10.20.3.149)
    transmit(10.20.3.149)
    receive(10.20.3.149)
    transmit(10.20.3.149)
    receive(10.20.3.149)
    transmit(10.20.3.149)
    receive(10.20.3.149)
    10.20.3.149: Server dropped: Server has gone too long without sync
    server 10.20.3.149, port 123
    stratum 5, precision -22, leap 00, trust 000
    refid [10.20.3.149], delay 0.02838, dispersion 0.00037
    transmitted 4, in filter 4
    reference time:    00000000.00000000  Sun, Dec 31 1899 19:00:00.000
    originate timestamp: db58798a.31270a17  Fri, Aug 12 2016 12:36:26.192
    transmit timestamp:  db58798e.185b391c  Fri, Aug 12 2016 12:36:30.095
    filter delay:  0.02843  0.02838  0.02869  0.02863
             0.00000  0.00000  0.00000  0.00000
    filter offset: -3.90380 -3.90424 -3.90470 -3.90468
             0.000000 0.000000 0.000000 0.000000
    delay 0.02838, dispersion 0.00037
    offset -3.904242

    12 Aug 12:36:30 ntpdate[2197]: no server suitable for synchronization
found

I see the reference time is way off (even though the system time is
correct) - is that what's triggering the message `Server has gone too long
without a sync`?  I don't care if the time isn't 100% exactly right as long
as the two boards are synced together. Is there a way to force the two
boards to sync regardless of when the last server sync was?

Thanks,
Jason


More information about the questions mailing list