[ntp:questions] Use ntp orphan mode to sync time two stand-alone computers

Jason Beach jason.m.beach at gmail.com
Tue Aug 16 21:09:50 UTC 2016


It appears all I needed was to replace the "tos orphan 5" in the TK1's
ntp.conf file with:

server 127.127.1.0
fudge 127.127.1.0 stratum 5

I had tried using the fudge line earlier, but I think I substituted the
actual IP address of the TK1 and omitted the server 127.127.1.0 line. I
also commented out server lines for internet servers that weren't available.

Thanks for your help on this.

Thanks,
Jason

On Mon, Aug 15, 2016 at 8:00 AM, <questions-request at lists.ntp.org> wrote:

> Send questions mailing list submissions to
>         questions at lists.ntp.org
>
> To subscribe or unsubscribe via the World Wide Web, visit
>         http://lists.ntp.org/listinfo/questions
> or, via email, send a message with subject or body 'help' to
>         questions-request at lists.ntp.org
>
> You can reach the person managing the list at
>         questions-owner at lists.ntp.org
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of questions digest..."
>
>
> Today's Topics:
>
>    1. Use ntp orphan mode to sync time two stand-alone  computers
>       (Jason Beach)
>    2. Re: Use ntp orphan mode to sync time two stand-alone
>       computers (Brian Inglis)
>    3. Re: Use ntp orphan mode to sync time two stand-alone
>       computers (Miroslav Lichvar)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Sat, 13 Aug 2016 21:28:52 -0400
> From: Jason Beach <jason.m.beach at gmail.com>
> To: questions at lists.ntp.org
> Subject: [ntp:questions] Use ntp orphan mode to sync time two
>         stand-alone     computers
> Message-ID:
>         <CAEjinXDeN6kgT_+Af-Kev17DQQEZekum0R+
> NwrhLh9v6br90_Q at mail.gmail.com>
> Content-Type: text/plain; charset=UTF-8
>
> I have two arm-based Linux (ubuntu 14.04) computers, a Jetson TK1 and TX1
> that will fly on a multicopter and hence have no internet connection (they
> are networked together onboard).  They also do not have RTC's built-in but
> I have added a smll external one (https://www.adafruit.com/product/255) to
> the Jetston TK1.  The TK1's time gets set on boot from this RTC no problem
> (using a `sudo hwclock -s -f /dev/rtc0` in rc.local).  I am trying to get
> the TX1 to sync to the TK1's time using ntp.
>
> The TK1's ntp.conf file contains:
>
>     driftfile /var/lib/ntp/ntp.drift
>
>     server 0.us.pool.ntp.org
>     server 1.us.pool.ntp.org
>     server 2.us.pool.ntp.org
>     server 3.us.pool.ntp.org
>
>     tos orphan 5
>
> The TX1's ntp.conf file contains:
>
>     driftfile /var/lib/ntp/ntp.drift
>
>     # Specify one or more NTP servers.
>
>     server 10.20.3.149 iburst prefer
>
>     server 0.ubuntu.pool.ntp.org
>     server 1.ubuntu.pool.ntp.org
>     server 2.ubuntu.pool.ntp.org
>     server 3.ubuntu.pool.ntp.org
>
> where 10.20.3.149 is the IP address of the TK-1. If I run `ntpq -p` I get
>
>          remote           refid      st t when poll reach   delay   offset
>  jitter
>
> ============================================================
> ==================
>      192.168.0.10    .INIT.          16 -    -  512    0    0.000    0.000
>   0.000
>      192.168.3.149   .INIT.          16 -    -  512    0    0.000    0.000
>   0.000
>
> and if I run `ntpdate -dv 10.20.3.149` I get
>
>     12 Aug 12:36:23 ntpdate[2197]: ntpdate 4.2.6p5 at 1.2349-o Thu Feb 11
> 18:30:14 UTC 2016 (1)
>     Looking for host 10.20.3.149 and service ntp
>     host found : TK-Astro
>     transmit(10.20.3.149)
>     receive(10.20.3.149)
>     transmit(10.20.3.149)
>     receive(10.20.3.149)
>     transmit(10.20.3.149)
>     receive(10.20.3.149)
>     transmit(10.20.3.149)
>     receive(10.20.3.149)
>     10.20.3.149: Server dropped: Server has gone too long without sync
>     server 10.20.3.149, port 123
>     stratum 5, precision -22, leap 00, trust 000
>     refid [10.20.3.149], delay 0.02838, dispersion 0.00037
>     transmitted 4, in filter 4
>     reference time:    00000000.00000000  Sun, Dec 31 1899 19:00:00.000
>     originate timestamp: db58798a.31270a17  Fri, Aug 12 2016 12:36:26.192
>     transmit timestamp:  db58798e.185b391c  Fri, Aug 12 2016 12:36:30.095
>     filter delay:  0.02843  0.02838  0.02869  0.02863
>              0.00000  0.00000  0.00000  0.00000
>     filter offset: -3.90380 -3.90424 -3.90470 -3.90468
>              0.000000 0.000000 0.000000 0.000000
>     delay 0.02838, dispersion 0.00037
>     offset -3.904242
>
>     12 Aug 12:36:30 ntpdate[2197]: no server suitable for synchronization
> found
>
> I see the reference time is way off (even though the system time is
> correct) - is that what's triggering the message `Server has gone too long
> without a sync`?  I don't care if the time isn't 100% exactly right as long
> as the two boards are synced together. Is there a way to force the two
> boards to sync regardless of when the last server sync was?
>
> Thanks,
> Jason
>
>
> ------------------------------
>
> Message: 2
> Date: Sun, 14 Aug 2016 11:00:22 -0600
> From: Brian Inglis <Brian.Inglis at SystematicSw.ab.ca>
> To: questions at lists.ntp.org
> Subject: Re: [ntp:questions] Use ntp orphan mode to sync time two
>         stand-alone computers
> Message-ID: <4f106def-e56f-6256-2a76-b34f9759c7e1 at SystematicSw.ab.ca>
> Content-Type: text/plain; charset=utf-8; format=flowed
>
> On 2016-08-13 19:28, Jason Beach wrote:
> > I have two arm-based Linux (ubuntu 14.04) computers, a Jetson TK1 and TX1
> > that will fly on a multicopter and hence have no internet connection
> (they
> > are networked together onboard).  They also do not have RTC's built-in
> but
> > I have added a smll external one (https://www.adafruit.com/product/255)
> to
> > the Jetston TK1.  The TK1's time gets set on boot from this RTC no
> problem
> > (using a `sudo hwclock -s -f /dev/rtc0` in rc.local).  I am trying to get
> > the TX1 to sync to the TK1's time using ntp.
>
> > I see the reference time is way off (even though the system time is
> > correct) - is that what's triggering the message `Server has gone too
> long
> > without a sync`?  I don't care if the time isn't 100% exactly right as
> long
> > as the two boards are synced together. Is there a way to force the two
> > boards to sync regardless of when the last server sync was?
>
> Remove all inaccessible internet servers as they will make it impossible
> for the systems to sync; define each system to the other; then see docs
> about setting up Orphan Mode:
>
> http://doc.ntp.org/cgi-bin/htsearch?method=and&sort=
> score&restrict=4.2.6p5&words=orphan+mode
>
> --
> Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada
>
>
> ------------------------------
>
> Message: 3
> Date: Mon, 15 Aug 2016 11:38:26 +0200
> From: Miroslav Lichvar <mlichvar at redhat.com>
> To: questions at lists.ntp.org
> Subject: Re: [ntp:questions] Use ntp orphan mode to sync time two
>         stand-alone computers
> Message-ID: <20160815093826.GB22836 at localhost>
> Content-Type: text/plain; charset=us-ascii
>
> On Sat, Aug 13, 2016 at 09:28:52PM -0400, Jason Beach wrote:
> > I have two arm-based Linux (ubuntu 14.04) computers, a Jetson TK1 and TX1
> > that will fly on a multicopter and hence have no internet connection
> (they
> > are networked together onboard).  They also do not have RTC's built-in
> but
> > I have added a smll external one (https://www.adafruit.com/product/255)
> to
> > the Jetston TK1.  The TK1's time gets set on boot from this RTC no
> problem
> > (using a `sudo hwclock -s -f /dev/rtc0` in rc.local).  I am trying to get
> > the TX1 to sync to the TK1's time using ntp.
>
> If you need to sync one machine to another, you should use the LOCAL
> driver (127.127.1.0) and not the orphan mode. Orphan mode is for cases
> where a server should be automatically selected from a group of
> unsynchronised servers. In your case only machine can be a server (the
> one with RTC).
>
> --
> Miroslav Lichvar
>
>
> ------------------------------
>
> Subject: Digest Footer
>
> _______________________________________________
> questions mailing list
> questions at lists.ntp.org
> http://lists.ntp.org/listinfo/questions
>
> ------------------------------
>
> End of questions Digest, Vol 142, Issue 1
> *****************************************
>


More information about the questions mailing list