[ntp:questions] NTP not reading from /etc/ntp.conf?

CubeCentral cubecentral at gmail.com
Thu Aug 3 15:06:42 UTC 2017

This is a classic problem that arises when the system is booting from DHCP.

This is a link I had saved that describes the problem and points to a

Please let me know if this worked and if my gut instinct was correct!

	-R. at CubeCentral

-----Original Message-----
From: questions
[mailto:questions-bounces+cubecentral=gmail.com at lists.ntp.org] On Behalf Of
Dan Geist
Sent: Thursday, August 3, 2017 07:00
To: Kevin Chan <kschan at mit.edu>
Cc: questions <questions at lists.ntp.org>
Subject: Re: [ntp:questions] NTP not reading from /etc/ntp.conf?

Check the process running with something like "ps -Aef | grep ntpd" to be
sure things are running how you think they are. "/etc/ntp.conf" is the
default but there may be something passing an alternate config file to the
daemon with the -c flag on startup.

Also, see if you have something like timemaster running. It manages multiple
time protocol sources (like ntp, p2p...) and rewrites configs for them as


Dan Geist dan(@)polter.net

----- On Aug 2, 2017, at 5:48 PM, Kevin Chan kschan at mit.edu wrote:

> I'm on an imx233 arm processor using Debian 7.0 with kernel version 
> 3.12
> I'm having issues configuring ntpd to read from a gps source. I have 
> tried adding server entries in /etc/ntp.conf, but those changes have 
> no effect on the sources listed in ntpq -p
> The only thing I see is:
> root at arm:~# ntpq -p
>     remote           refid      st t when poll reach   delay   offset
> jitter
> *  4 u    -   64    1    1.194  -21.122
> 0.679
> I even deleted /etc/ntp.conf and restarted the ntp service with "sudo 
> service ntp restart" and I still see the same entry in ntpq... Is ntp 
> reading from a different configuration file somewhere? Thanks in 
> advance
> --
> Kevin Chan
questions mailing list
questions at lists.ntp.org

More information about the questions mailing list