[ntp:questions] NTP 4.2.8p10 released

David Taylor david-taylor at blueyonder.co.uk.invalid
Sun Mar 26 16:49:16 UTC 2017


On 25/03/2017 22:09, Dan Gearty wrote:
> I have been using the loopback driver on Windows 10.
> It had been running OK in older versions up to 4.2.8p9.
> Now in 4.2.8p10 it appears that junk characters are appended to the driver
> name when it is called.  The junk characters are different each time NTP is
> restarted.
>
> 25 Mar 16:57:32 ntpd[14436]: load_pps_provider: 'C:\Program Files
> (x86)\NTP\bin\loopback-ppsapi-provider.dll???????nY?': The specified module
> could not be found
> 25 Mar 16:57:32 ntpd[14436]: time_pps_create: load failed (C:\Program Files
> (x86)\NTP\bin\loopback-ppsapi-provider.dll???????nY?) --> 2 / No such file
> or directory
> 25 Mar 16:57:32 ntpd[14436]: load_pps_provider: 'C:\Program Files
> (x86)\NTP\bin\??h?l?': The specified module could not be found
> 25 Mar 16:57:32 ntpd[14436]: time_pps_create: load failed (C:\Program Files
> (x86)\NTP\bin\??h?l?) --> 2 / No such file or directory
> 25 Mar 16:57:32 ntpd[14436]: load_pps_provider: 'C:\Program Files
> (x86)\NTP\bin\A': The specified module could not be found
> 25 Mar 16:57:32 ntpd[14436]: time_pps_create: load failed (C:\Program Files
> (x86)\NTP\bin\A) --> 2 / No such file or directory
> 25 Mar 16:57:32 ntpd[14436]: time_pps_create: no providers available
> 25 Mar 16:57:32 ntpd[14436]: refclock_ppsapi: time_pps_create: Exec format
> error
> 25 Mar 16:57:32 ntpd[14436]: GPS_NMEA(4) flag1 1 but PPSAPI fails

Dan,

Sorry to hear of the problem.  PCs Harstad and Lund here are using the 
loopback DLL and are still working correctly:

   http://www.satsignal.eu/mrtg/harstad_ntp_2.html
   http://www.satsignal.eu/mrtg/lund-ntp-2.html

Note that I install NTP outside the "Program Files" tree to avoid 
permissions issues, and most likely I have /not/ updated the loopback DLL.

The NTP executables are from my own build:
   http://www.satsignal.eu/ntp/x86/index.html

and checking...the loopback DLL details are:
   18/06/2016  15:51            75,776 loopback-ppsapi-provider.dll

installed in C:\Tools\NTP\bin\ in each case.  So that DLL version /does/ 
work with 4.2.8p10 binaries.  Checked on Win-10/64 in each case.

-- 
Cheers,
David
Web: http://www.satsignal.eu



More information about the questions mailing list