[ntp:questions] change between 4.2.8p6 and 4.2.8p10 release - SHM

MAYER Hans Hans.Mayer at iiasa.ac.at
Tue Mar 28 14:06:06 UTC 2017



Dear All, 

My environment a GPS disciplined NTP server running on armv7l GNU/Linux with kernel 3.4.108+ 
gpsd version 3.15 

This is the relevant part of the configuration

# Enabling PPS/ATOM support
server 127.127.22.0 minpoll 4 maxpoll 4
fudge 127.127.22.0 refid PPS time1 0.000001
fudge 127.127.22.0 flag3 1 flag4 1  # enable kernel PLL/FLL clock discipline and clockstats

# gpsd shared memory clock
server 127.127.28.0 minpoll 4 maxpoll 4 prefer  # PPS requires at least one preferred peer
fudge 127.127.28.0 refid GPS
fudge 127.127.28.0 time1 +0.1565 flag4 1 # coarse processing delay offset


Now I tried to update my NTP server from version 4.2.8p6 to version 4.2.8p10. 
I watched the daemon log and I can see a lot of entries like this:  ( repeating and repeating ) 

Mar 28 09:11:01 gps0 ntpd[2445]: 0.0.0.0 0168 08 no_sys_peer 
Mar 28 09:11:03 gps0 ntpd[2445]: PPS(0) 916a 8a sys_peer 
Mar 28 09:11:17 gps0 ntpd[2445]: 0.0.0.0 0178 08 no_sys_peer 
Mar 28 09:12:21 gps0 ntpd[2445]: PPS(0) 917a 8a sys_peer 
Mar 28 09:13:57 gps0 ntpd[2445]: 0.0.0.0 0188 08 no_sys_peer 
Mar 28 09:14:13 gps0 ntpd[2445]: PPS(0) 918a 8a sys_peer 
Mar 28 09:15:17 gps0 ntpd[2445]: 0.0.0.0 0198 08 no_sys_peer 
Mar 28 09:17:09 gps0 ntpd[2445]: PPS(0) 919a 8a sys_peer 
Mar 28 09:21:25 gps0 ntpd[2445]: 0.0.0.0 01a8 08 no_sys_peer 
Mar 28 09:21:57 gps0 ntpd[2445]: PPS(0) 91aa 8a sys_peer 
Mar 28 09:22:13 gps0 ntpd[2445]: 0.0.0.0 01b8 08 no_sys_peer

Looking with ntpq after a no_sys_peer I see: 

# ntpq -pn
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
x127.127.22.0    .PPS.            0 l    7   16  377    0.000   -0.068   0.119
x127.127.28.0    .GPS.            0 l    7   16  377    0.000   -4.665   0.688

But it should be generally

o127.127.22.0    .PPS.            0 l   13   16  377    0.000   -0.005   0.010
*127.127.28.0    .GPS.            0 l   12   16  377    0.000   46.881   1.041


So in more or less regular intervals ntpd goes into state "falsetick" but comes back to status "pps" and so on. 

I changed back to version 4.2.8p6 and everything is fine. 
I have a small script where I can see availability.  In file "plot_486p10.png" you can see that the bottom line between 07:00 and 08:00 jumps between "falsetick" and "pps". 
This is the time frame where I run version 4.2.8p10. 
A day before "plot_486p6.png" shows ( where I run version 4.2.8p6 ) the driver 127.127.22.0 is constantly available. 
In a test environment I figured out the issue exists with version 4.2.8p9 too. So something changed in the last 4 patch level versions. 

To locate this issue a little bit I removed driver 127.127.28.0  and I used another ntp server over IP as a "preferred server". 
In this case version 4.2.8p10 works fine with 127.127.22.0. So it must have something to do with the shared memory driver 127.127.28.0  

Any ideas what I could do to fix this issue ? 
Did someone else figure out the same issue ? 
Is it worth to open a ticket ? 


Kind regards
Hans




--

Ing. Dipl.-Ing. Hans Mayer
Systems Administrator
Information and Communication Technologies (ICT)

International Institute for Applied Systems Analysis (IIASA)
Schlossplatz 1
A-2361 Laxenburg, Austria
Phone: +43 2236 807 Ext 215
Mobile: +43 676 83 807 215
Web: http://www.iiasa.ac.at
E-Mail: mayer at iiasa.ac.at








More information about the questions mailing list