[ntp:questions] NTPd in embedded application slow to serve/sync time.

Gary E. Miller gem at rellim.com
Thu Aug 16 20:19:59 UTC 2018

Yo Ben!

On Thu, 16 Aug 2018 11:16:48 -0500
Ben <bkamen at benjammin.net> wrote:

> One of them has a garmin GPS18 via ttyUSBn port (linked to /dev/gps0)
> and works great...  have "minpoll" set to 3 for fast poll time.

Is your PPS also set to prefer?

> The other system is set to use this first unit as its time source --

Have you considered also getting time from a pool server?

> in a script both show that "ERROR 5" basically telling me (without
> digging further) the server clock isn't fully happy yet...

Have you tried the ntpd -q option?

Have you tried setting the time, from another chimer, on your server
before starting ntpd?

Gary E. Miller Rellim 109 NW Wilmington Ave., Suite E, Bend, OR 97703
	gem at rellim.com  Tel:+1 541 382 8588

	    Veritas liberabit vos. -- Quid est veritas?
    "If you can’t measure it, you can’t improve it." - Lord Kelvin
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 851 bytes
Desc: OpenPGP digital signature
URL: <http://lists.ntp.org/pipermail/questions/attachments/20180816/2e75e3d2/attachment.sig>

More information about the questions mailing list