[ntp:questions] NTPD seemingly ignoring time1 fudge for NMEA ref clock

O'Connor, Daniel darius at dons.net.au
Wed Aug 21 05:13:49 UTC 2019


Hi,
I am attempting to setup NTPD on a Beaglebone Black running FreeBSD 13 (ntpd 4.2.8p12-a (1)) connected to a Skytraq Venus638FLPx (https://www.sparkfun.com/products/retired/11058). The 1PPS is connected to a timer capture input and the kernel is successfully processing those.

However I want to also have it parse the NMEA output but it persistently shows an offset and seemingly ignores the time1 fudge I apply.


I tried following this https://gpsd.gitlab.io/gpsd/gpsd-time-service-howto.html and produced the following graph:



So my ntp.conf is..
server 10.0.2.1 iburst prefer

# NMEA on /dev/gps0 at 9600 baud, process GPGGA only
server 127.127.20.0 mode 0x12 minpoll 4 maxpoll 4 noselect
fudge  127.127.20.0 time1 0.129 stratum 10 refid GPS

# PPS from dmtpps, use kernel
server 127.127.22.0 minpoll 4 maxpoll 4
fudge  127.127.22.0 refid PPS

statsdir /var/db/ntp
statistics loopstats peerstats clockstats
filegen loopstats file loopstats type day enable
filegen peerstats file peerstats type day enable
filegen clockstats file clockstats type day enable

However the offset is still ~0.129 -
[gps 5:07] ~ >ntpq -nc pe
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
*10.0.2.1        27.124.125.250   3 u   25   64  377    0.373   -0.279   0.048
 127.127.20.0    .GPS.           10 l   16   16  377    0.000  -129.46   0.058
o127.127.22.0    .PPS.            0 l   15   16  377    0.000   -0.006   0.004

I have tried several values for time1 but nothing seems to affect it. I have restarted ntpd after making the changes and waited an hour or so for it to stabilise.

Any suggestions for the obvious thing I have probably missed would be gratefully received.

Thanks :)

--
Daniel O'Connor
"The nice thing about standards is that there
are so many of them to choose from."
 -- Andrew Tanenbaum




More information about the questions mailing list