[ntp:questions] Make fail on macOS Mojave "ld: library not found for -lcrypto.35"

James Brown jlbrown at bordo.com.au
Wed Mar 27 07:01:54 UTC 2019

Since Apple no longer ships ntpd with macOS, I’m trying to compile and install it.

Unfortunately ‘make’ always stops with:

ld: warning: directory not found for option '-F/BuildRoot/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.14.Internal.sdk/System/Library/PrivateFrameworks/'
ld: warning: directory not found for option '-F/BuildRoot/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.14.Internal.sdk/System/Library/Frameworks/'
ld: library not found for -lcrypto.35
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[3]: *** [ntpsnmpd] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

I’ve tried various combinations of ./configure (with and without options). Eg:

./configure --with-crypto=openssl --with-openssl-libdir="/usr/local/opt/openssl/lib" --with-openssl-incdir="/usr/local/opt/openssl/include"
Have also tried putting:

export LDFLAGS="-L/usr/local/opt/openssl/lib"
export CPPFLAGS="-I/usr/local/opt/openssl/include”

Before the ‘configure’ command.

Ntp version 4.2.8p13

Any suggestions?



More information about the questions mailing list