[Fwd: Re: [ntp:hackers] Weekend error report]

Danny Mayer mayer at gis.net
Tue Oct 5 22:38:18 PDT 2004

At 12:47 AM 10/6/2004, David L. Mills wrote:

>>About the build. Originally, bridgeport and baldwin were to mount 
>>pogo:/usr/local, but I see that is not the case. However, I see evidence 
>>somebody (you?) built on bridgeport.

It was the case when I used it. However, the disk is full on bridgeport so 
any build
is likely to fail. I didn't build on bridgeport but since the pogo disk was 
I used the pogo build to test on bridgeport. I suspect your build failed 
of the disk space problem.

When I ran ntpd on bridgeport I didn't see any broadast packets arrive even
though rackety was supposedly acting as a broadcast server. I couldn't tell
why, or if I waited long enough. How frequently is a broadcast packet supposed
to go out? It was receiving packets from the other servers listed.

Are there any other nodes receiving broadcast packets?


>>At 12:37 AM 9/27/2004, Danny Mayer wrote:
>>>>At 10:59 PM 9/26/2004, David L. Mills wrote:
>>>>>At the moment on the campus wire, rackety is broadcasting but 
>>>>>bridgeport is not receiving.
>>>>I just took over bridgeport to see what was happening. It put it back. 
>>>>are a number of problems:
>>>>1) It's out of disk space so it can't write anything to disk.
>>>>2) It's running an older build dated Sep 2 and not what you installed 
>>>>3) It's not receiving broadcast packets at all from what I can tell. It 
>>>>does show
>>>>that it was enabled to receive broadcast packets. How often does a 
>>>>packet get sent? I only had a few minutes on which may not have been
>>>>long enough. Are you sure rackety is sending broadcast packets?
>>>>>  If albert is segfaulting somewhere in the address prettyprint 
>>>>> routine and porkypine comes bum in that area, could there be a 
>>>>> connection? The gdb bt got nowhere near the resolver library. Problem 
>>>>> is, ntpq can't print addresses either. That may be a clue.
>>>>We don't know what the problem is with albert except it was segfaulting 
>>>>trying to get addresses. Harlan may have something to say here when he
>>>>gets back. porkypine is, well, porkypine. Although it runs, everything 
>>>>I tried
>>>>to get an address back fails. This being an ancient box, I'm not sure how
>>>>hard we should try. Every idea I had failed.
>>>>>Both Linux mort and Freebie howland eventually resolved there 
>>>>>differences with rackety autokey, but I don't know why it took several 
>>>>>repeats of the signature request. Poor SunOS rackety might be running 
>>>>>out of steam.
>>>>That could be. Is it that overloaded? I'm not sure why it would require 
>>>>tries unless the requests are timing out. Could that be what is happening?

More information about the hackers mailing list