[ntp:hackers] Re: Anybody object to requiring AnsiC for building NTP?

Mark Martinec Mark.Martinec at ijs.si
Wed May 25 07:01:39 PDT 2005


>From Harlan:
> >One of the requirements of NTP has been that it compile on systems
> >without Ansi C compilers.
> >I'm thinking that it's time we remove this backward-compatibility
> >requirement.

> >Does anybody have a requirement to still support K&R compilers?

Not that I would know.
If there is such a system around, it is also very likely it wants
to run ancient xntpd until it falls apart.

I cleaned driver29 (Palisade) some time ago of the non-ANSI stuff
to avoid the mess. (and fixed few things; still need to introduce
the new Dave's quick-startup feature before submitting it).

>From Dave:
> I have no idea how to respond to this. Which opeating systems are
> affected? Solaris native> Alpha native? VMS native? Are non-ANSI
> compilers rare?

Old VAX C was non-ANSI, but nowadays VMS has a decent ANSI C compiler.
Tru64 C compiler is ANSI as well.

  Mark



More information about the hackers mailing list