[ntp:hackers] Re: configuration file rewrite
jpp at cloudview.com
Fri Mar 3 00:26:20 UTC 2006
Martin Burnicki wrote:
> If the configuration file code is being rewritten, what do you all think about
> replacing the "restrict" parameter by something like "allow" and/or "deny",
> like it is used by other programs?
> As we can see in the newsgroup, usage of "restrict" is often found ambiguous,
> and misunderstood by users, especially since its meaning has changed some
> time ago.
Whatever happens in the rewrite please please please don't change the
meaning of any existing config keywords (by all means deprecate them if
needed just don't re-use them to mean something else)- if something new
is needed use a new keyword - having the same keyword mean different
things in different versions of a program is grounds for an F in my book.
More information about the hackers