[ntp:hackers] Autokey users - please read

Harlan Stenn stenn at ntp.org
Thu Sep 10 00:11:52 UTC 2009


https://support.ntp.org/bugs/show_bug.cgi?id=1243 talks about a bug that
affects autokey users.

We have a fix ready to go.

There are 2 ways to go, however.

One way is to just fix the problem, which will mean an "old" version of
ntpd will not authenticate with a "new" version of ntpd.

The other way is to provide a backward-compatibility mode, and there
would be a switch in the config file that would say whether or not the
backward-compatible mechanism should be enabled or not.

Does anybody *know* that:

- they are actively using autokey
- they would have difficulty updating all of their autokey-using hosts
  at the same time
- and therefore they would appreciate our implementing the backward-
  compatibility fix

-- 
Harlan Stenn <stenn at ntp.org>
http://ntpforum.isc.org  - be a member!


More information about the hackers mailing list