[ntp:questions] Newbie problems

stan at cider.for.me.uk stan at cider.for.me.uk
Fri Aug 22 09:12:27 UTC 2003


Hello all!
(Sorry if I've included too much info.)

Running Slackware 8.0 and
NTP4 4.0.99k23 Sun Apr  8 15:36:43 PDT 2001 (1).

I just want to sync the Slackware box (i.e. client only, not to serve 
the LAN).

/etc/ntpd.conf has:
server  128.118.25.3
driftfile /etc/ntp/drift
logconfig +allclock +allinfo +allevents +allstatistics +allsync +allpeer
logfile /var/log/ntp.log
authenticate no

(most recently attempted) command is:
ntpd -qgnAc /etc/ntpd.conf

ps -ef says:
root     21134  6613  0 08:52 pts/0    00:00:00 ntpd -qgnAc 
/etc/ntp.conf
root     21135 21134  0 08:52 pts/0    00:00:00 ntpd -qgnAc 
/etc/ntp.conf
root     21136 21135  0 08:52 pts/0    00:00:00 ntpd -qgnAc 
/etc/ntp.conf

less ntp.log says:
22 Aug 08:52:19 ntpd[21134]: system event 'event_restart' (0x01) status 
'sync_alarm, sync_unspec, 1 event, event_unspec' (0xc010)
ntp.log lines 1-1/1 (END)

But ntpq host says:
127.0.0.1
why???

I worked around this with:
ntpq host 128.118.25.3
and then....

ntpq rv says:
status=06f4 leap_none, sync_ntp, 15 events, event_peer/strat_chg,
processor="sun4u", system="SunOS5.7", leap=00, stratum=2, precision=-15,
rootdelay=26.333, rootdispersion=39.514, peer=13591,
refid=ntp2.usno.navy.mil,
reftime=c2f05545.dcded288  Fri, Aug 22 2003  9:39:33.862, poll=10,
clock=c2f0581c.a310dbf0  Fri, Aug 22 2003  9:51:40.636, state=4,
phase=-1.177, frequency=22.940, jitter=13.074, stability=0.054

which suggests it's working. But
date says:
Fri Aug 22 09:45:12 BST 2003
and hwclock says:
Fri Aug 22 09:47:10 2003  -0.910166 seconds
which suggests it isn't.

Any ideas please?
-- 
Cheersh!



More information about the questions mailing list