[ntp:questions] NTP client as service on Win2K

David W.E. Roberts nospam at talk21.com
Fri Aug 22 10:29:56 UTC 2003


built into Win2K is a time service.

According to web based instructions and the command line help you can set
the identity of a remote NTP server.
You then run the NTP client as a service and all should be fine.

However, if I use the 'net time' command in a command window, I get the

"C:\>net time
Could not locate a time-server.

More help is available by typing NET HELPMSG 3912."

the time server is set O.K - I have tried several tier 2 servers from
http://www.eecis.udel.edu/~mills/ntp/clock2a.html as well as trying my ISP's
time server, all with the same result.

"C:\>net time /querysntp
The current SNTP value is:

The command completed successfully."

the above seems to suggest I have a valid IP address configured.

So, please:

(1) am I just being unlucky and trying time servers which are no longer

(2) am I misunderstanding the function of the 'net time' command - i.e. I
think it should return the current network time from a time server

(3) is there a reason that Win2k cannot use remote (across Internet) time
servers e.g. it is trying RPC or something similar?

Any alternatives?

I am on an ADSL line behind a NAT router.

Dave R


More information about the questions mailing list