[ntp:questions] NTP 4.2.0 build configuration

Carsten P. Gehrke carsten at gehrke.org
Thu Nov 27 08:25:33 UTC 2003


I just built ntp-4.2.0 with these commands:

as an unprivileged user:
./configure --prefix=/usr --sysconfdir=/etc \
   --localstatedir=/var/lib/ntp --with-crypto=openssl \
   --disable-all-clocks --disable-parse-clocks
make

as root:
make install

If I run ntpd, it silently dies.  The system log contains:
... ntpd[3175]: ntpd 4.2.0 at 1.1164-r Wed Nov 26 20:10:10 PST 2003 (1)
... ntpd[3175]: signal_no_reset: signal 13 had flags 4000000
... ntpd[3175]: precision = 4.000 usec
... ntpd[3175]: no IPv6 interfaces found
... ntpd[3175]: kernel time sync status 0040

If I run ntpd -q, I get a segfault, but no core
ntpd -g also dies quietly

The file /etc/ntp.conf exists, and contains the lines:
driftfile /var/lib/ntp/ntp.drift
server timeserver prefer

timeserver is the name of another host on my network running ntp-4.1.1 
without problems.  That server gets its time from public time servers, 
and distributes it on my LAN.

Did I configure the source incorrectly?  I had installed the openssl 
library before ntp.  I don't have gdb installed on this system.

TIA,
Carsten




More information about the questions mailing list