[ntp:questions] Re: Redefinition Error with NTP-4.2.0 on OpenBSD

Terje Mathisen terje.mathisen at hda.hydro.com
Wed Oct 29 09:30:14 UTC 2003

Danny Mayer wrote:

> Terje Mathisen <terje.mathisen at hda.hydro.com> wrote in message news:<bnltpj$i0p$1 at osl016lin.hda.hydro.com>...
>>Danny Mayer wrote:
>>>It sounds like it didn't recognize that it has definitions for IPv6 since
>>>that header file ntp_rfc2553.h is only needed if IPv6 definitions are not

>>I'm hitting the same kinds of errors on an old AIX machine (4.3.3), 
>>while on an even older (4.2.1) machine there's no trace of IPv6. On this 
>>system it crashes due to incompatibilites between the system and gnu 
>>include files. :-(
> We don't have access to AIX machines so we need a volunteer to look at
> it. We also have Bug #135 which is partly related to this. It's not clear
> from your message if you mean the AIX 4.2.1 causes the build to fail and
> in what way or what were the error messages.

As I wrote, I have all sorts of AIX machines here, from 4.2.1, via 4.3.* 
to 5.*.

The new v5 machines seems OK, the one I tested on is currently running 
ntp 4.2.0 quite happily.

As I tried to write above, I've seen two different error conditions on 
the aix 4 machines:

aix 4.2.1 with gcc crashes due to some kind of incompatibility between 
the system and gnu include files:
Making all in libntp
make[2]: Entering directory `/tmp_mnt/h/terjem/ntp-4.2.0/libntp'
source='icom_.c' object='icom_.o' libtool=no \
depfile='.deps/icom_.Po' tmpdepfile='.deps/icom_.TPo' \
depmode=gcc /bin/sh ../depcomp \
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../include -I../include    -g -O2 
-Wall -Wcast-qual -Wmissing-prototypes -Wpointer-arith -Wshadow 
-Wstrict-prototypes -c `test -f 'icom_.c' || echo './'`icom_.c
In file included from /usr/include/sys/lockf.h:41,
                  from ./icom.c:9:
/usr/include/sys/stat.h:92: parse error before `blkcnt_t'
/usr/include/sys/stat.h:92: warning: no semicolon at end of struct or union
/usr/include/sys/stat.h:107: parse error before `}'
make[2]: *** [icom_.o] Error 1
make[2]: Leaving directory `/tmp_mnt/h/terjem/ntp-4.2.0/libntp'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp_mnt/h/terjem/ntp-4.2.0'
make: *** [all] Error 2
terjem at vkhdib01 /h/terjem/ntp-4.2.0>
terjem at vkhdib01 /h/terjem/ntp-4.2.0>

I do notice that the gnu includes are for aix 4.1.1, which might be 

Anyway, on the aix 4.3.3 system, the compile errors seem to be caused by 
incompatibilites between the ntp_rfc2553.h include file and the 
(rudimentary?) ipv6 definitions in the OS.

I did try to #ifdef away the ntp_rfc2553.h stub file contents, but that 
just proved that most of the ipv6 definitions are missing.

Is there an easy way to build ntp totally without ipv6 support these 
days? I tried to look for ./configure options, but couldn't locate any. :-(


- <Terje.Mathisen at hda.hydro.com>
"almost all programming can be viewed as an exercise in caching"

More information about the questions mailing list