[ntp:questions] synchronization failed

Vincent Blondel vincent.blondel at chello.be
Mon Nov 1 18:06:29 UTC 2004

I get some problems when trying to synchronize some corporate machines
(mandrake 10.1) with one of my public servers (FreeBSD 4.10) connected
on internet.

My configuration is composed from one public server that is synchronized
with ntp[1,2].belbone.be that serves this time to my corporate machines
where /etc/ntp.conf is automatically generated through a dhcp

I tried to upgrade my FreeBSD server with the last development ntpd
package but this didn't change anything.

Please find below some descriptions of my clients/servers configuration
files and error messages I found on both systems.


Public Server  : - hostname : sbegfxab
                 - IP :
                 - FreeBSD 4.10 (connected to the net) (ntp devel)
                 - /etc/ntp.conf written manually (see below)
Corporate host : - hostname : wbedllfs
                 - IP :
                 - Mandrake linux 10.1 (ntp 4.2.0)
                 - /etc/ntp.conf (generated automatically with dhcpcd)
(see below)


FreeBSD (Public Server)


server ntp1.belbone.be prefer
server ntp2.belbone.be
driftfile /var/db/ntp.drift
restrict mask notrust nomodify notrap

/var/log/messages (when I run ntpd)

Nov  1 18:10:47 sbegfxab ntpd[35609]: ntpd 4.2.0a at 1.1253-o Mon Nov  1
15:00:06 GMT 2004 (1)


Mandrake (Corporate Machine)


restrict default noquery notrust nomodify
restrict mask
driftfile /etc/ntp.drift
logfile /var/log/ntp.log

error messages on the console (when I run ntpdate)

host found : sbegfxab
 1 Nov 18:45:50 ntpdate[21606]: no server suitable for synchronization
Looking for host and service ntp

/var/log/messages (when I run ntp)

Nov  1 18:13:38 wbedllfs ntpd[21049]: ntpd 4.2.0 at 1.1161-r Mon Sep 13
20:05:27 CEST 2004 (1)
Nov  1 18:13:38 wbedllfs ntpd[21049]: precision = 2.000 usec
Nov  1 18:13:38 wbedllfs ntpd[21049]: kernel time sync status 0040
Nov  1 18:13:38 wbedllfs ntpd[21049]: frequency initialized 0.000 PPM
from /etc/ntp.drift

... and nothing happens (I get no synchronization)

Has somebody an idea to solve this problem ???


More information about the questions mailing list