[ntp:questions] Re: which 2.6 linux PPS API for oncore modules??

Ulrich Windl Ulrich.Windl at RZ.Uni-Regensburg.DE
Wed Aug 10 10:32:34 UTC 2005


mike <michael.no.spam.cook at wanadoo.fr> writes:

> Paul.Croome at softwareag.com wrote:
> > Mike,
> > The configure output "checking for ONCORE Motorola VP/UT Oncore GPS...
> > no"
> > indicates that something is not OK.
> > Did you run ./configure --enable-ONCORE ? If you don't specify
> > --enable-ONCORE,
> > a dummy stub refclock_oncore.o is compiled. You certainly should not
> > have to
> > define CLOCK_ONCORE by hand.
> > Paul
> >
> Yes I had configured as suggested. I think the problem is that I have no
> PPSAPI support (2.6). I am investigating that.

Linux-2.6 without patch has no PPS API (AFAIK). There is a patch that does
implement a basic PPS API only (no new kernel clock).

Ulrich




More information about the questions mailing list