[ntp:questions] Re: ntpd not adjusting time anymore

R rashdir at sbcglobal.net
Thu Dec 1 17:23:53 UTC 2005


Here is more information... For some reason (legacy code and original
developer isn't around) the ntp.conf file looks like this:

trap 127.0.0.1
driftfile /etc/ntp.drift
tinker panic 0
tinker step 0
server 127.127.1.0 burst
fudge  127.127.1.0 stratum 13

# I renamed the actual server IP's to meaningful text.
server GPS_SERVER_IP iburst prefer
server SECONDARY_SERVER_IP iburst prefer

After reading and re-reading the ntp documentation ..... The "tinker
panic 0" isn't affecting us since our drift is only about 2 seconds in
2 days which is less than the 43 second every 1 day limitation.
The "tinker step 0" is what I'm not able to understand completely. It's
basically saying that no step's are allowed.

So on 3 machines I left the configuration as-is and on the 4th machine
I commented out the two tinker steps. One of the tinker enabled
machines lost sync after 9 hours and the offset after this loss is
2800msec. I'm thinking the moment it decides to stop updating the clock
it also resets /etc/ntp.drift to 0.000 which is what in there right
now.

The other 3 machines (2 with tinker enabled and 1 with tinker disabled)
are working fine and they do have some numbers in /etc/ntp.drift which
are not 0.000.

Our ntpd is kicked off from another executable so it's not easy to add
the -g option. Is it possible to configure something in the conf file?

Regards,
-R




More information about the questions mailing list