[ntp:questions] Re: ntpd not adjusting time anymore

R rashdir at sbcglobal.net
Thu Dec 1 21:11:06 UTC 2005


The first thing we do is use ntpdate to sync up the clocks. Then ntpd
runs. After a few hours/days/weeks of running we notice that we are off
by more than 1 second.

I ran the command you mentioned:
ntpq -c 'rv 0'
status=0644 leap_none, sync_ntp, 4 events, event_peer/strat_chg,
version="ntpd 4.1.1b at 1.829 Mon Nov 11 16:42:00 EST 2002 (1)",
processor="ppc", system="Linux2.4.18-cp3g.halx303-ir01", leap=00,
stratum=2, precision=-17, rootdelay=2.524, rootdispersion=10.692,
peer=31693, refid=,
reftime=c739e0e8.32d5f138  Thu, Dec  1 2005 20:51:52.198, poll=6,
clock=c739e10f.ae96c3fc  Thu, Dec  1 2005 20:52:31.681, state=4,
offset=3019.685, frequency=0.000, jitter=0.772, stability=0.000

This is from the system which has panic 0 and step 0 enabled. Right now
it's out of sync with the NTP Server. I tried to understand what
"state=4" means but I can't seem to find it.

More information about the questions mailing list