[ntp:questions] Cannot configure ntp with pool

John A. Bailo jabailo at texeme.com
Fri Dec 2 00:32:31 UTC 2005


I am unable to get synchronization with my ntpd daemon and the ntp 
server pool.  I was able to get an initial sync to 0.pool.ntp.org using

[root at IVNWMAIL root]# ntpdate -u pool.ntp.org 
                             1 Dec 16:30:13 ntpdate[8168]: adjust time 
server 202.135.38.18 offset 0.089741 sec

and nmap -sU tells me the UPD port 123 is open.

Does anyone have it working and can help with my configuration?

I'm running Redhat 7.3 in line command mode as a mail server, so I need 
to know the config setting changes I need to make.

When I run:

[root at IVNWMAIL root]# ntpq -p

I see:

      remote           refid      st t when poll reach   delay   offset 
  jitter
==============================================================================
  LOCAL(0)        LOCAL(0)        10 l    4   64    1    0.000    0.000 
   0.004
  levy.catalyst.n 0.0.0.0         16 u    -   64    0    0.000    0.000 
4000.00
  adsl.remco.org  0.0.0.0         16 u    -   64    0    0.000    0.000 
4000.00
  tr.5sn.net      0.0.0.0         16 u    -   64    0    0.000    0.000 
4000.00
  clock2.redhat.c 0.0.0.0         16 u    -   64    0    0.000    0.000 
4000.00

The "4000.0" jitter means no sync.

Here are the entries in my /etc/ntpd.conf file:


# --- OUR TIMESERVERS -----
# or remove the default restrict line
# Permit time synchronization with our time source, but do not
# permit the source to query or modify the service on this system.

#  restrict mytrustedtimeserverip mask 255.255.255.255 nomodify notrap 
noquery
#  server mytrustedtimeserverip
#restrict 192.168.26.10 mask 255.255.255.255 nomodify notrap noquery
#server 192.168.26.10

server 0.pool.ntp.org iburst
server 1.pool.ntp.org iburst
server 2.pool.ntp.org iburst
server pool.ntp.org iburst





More information about the questions mailing list