[ntp:questions] Re: firewall setting question

mike michael.no.spam.cook at wanadoo.fr
Sat Dec 3 08:33:31 UTC 2005


Maybe not your firewall. I don't get any response from there either
with or without using an unprivilaged port.

You may be having a name server issue:
I got two different resolutions for that server???

[mike at quark mike]$ ntpdate -d stdtime.gov.hk
  3 Dec 09:18:37 ntpdate[32204]: ntpdate 4.2.0 at 1.1161-r Sat Aug 13 
11:39:52 CEST 2005 (5)
Looking for host stdtime.gov.hk and service ntp
host found : 210.0.235.14
transmit(210.0.235.14)
transmit(210.0.235.14)
transmit(210.0.235.14)
transmit(210.0.235.14)
transmit(210.0.235.14)
210.0.235.14: Server dropped: no data

[mike at quark mike]$ ntpdate -d  stdtime.gov.hk
  3 Dec 09:28:52 ntpdate[32463]: ntpdate 4.2.0 at 1.1161-r Sat Aug 13 
11:39:52 CEST 2005 (5)
Looking for host stdtime.gov.hk and service ntp
host found : 203.129.68.14
transmit(203.129.68.14)
transmit(203.129.68.14)
transmit(203.129.68.14)
transmit(203.129.68.14)
receive(203.129.68.14)
receive: pkt.org and peer.xmt differ
transmit(203.129.68.14)
203.129.68.14: Server dropped: no data

   That would explain getting a response some times but not at others.

Have a chat to their admin and get the IP address, rather than using the
dmain name.

Steve Kostecke wrote:
> On 2005-12-02, calendarw <calendarw at gmail.com> wrote:
> 
> 
>>I have installed a windows version of ntp server which named
>>ntp-4.2.0-nt, and I cannot use #ntpdate stdtime.gov.hk to get time
>>from time server. But it can use a #ntpdate -u stdtime.gov.hk get the
>>time sometime.
> 
> 
> The '-u' option causes ntpdate to use an unprivileged port (i.e >1024)
> instead of the NTP port (123).
> 
> You need to have port 123/UDP opened in all firewalls between your ntpd
> and the remote time servers.
> 




More information about the questions mailing list