[ntp:questions] Re: Windows timekeeping - sudden degradation- why?

David J Taylor david-taylor at blueyonder.co.not-this-bit.nor-this-part.uk.invalid
Sun Dec 11 17:39:43 UTC 2005

Danny Mayer wrote:
> David J Taylor wrote:
>> BTW: I've now written a program to force the MM timer to have a
>> resolution of 1ms permanently, and this seems to have fixed the
>> problem I had.
>> David
> This one interests me. What is it about the MM timer which makes the
> difference? Also what's the impact of doing this versus not doing this
> on other applications?
> Danny


Aside:  I've been getting direct e-mails from you which I thought should 
have appeared on the Usenet newsgroup.  Perhaps the list reflector is not 
working 100%?

The problems seems to be as (IIRC) Martin Burnicki explained, when 
switching between "1ms MM timer" and "normal 10/15ms timer", Windows 
inserts some sort of "adjustment", which causes the steps we've seen.  Why 
I only started seeing this ten days ago on the XP Pro system I don't know.

I now have been running with the MM timer enabled at 1ms on both Odin 
(1.9GHz Windows XP Pro SP2) and Stamsund (Windows 2000 WS) since Friday 
9th at 09:00 (56 hours) with no ill effects.


The stability on Odin appears to be restored, and there have been no 
timing steps on Stamsund like there were before.  Look at the Stamsund 
week graph!  A drastic improvement since last Wednesday.


My current view is that not only should NTP on Windows run with the 1ms MM 
timer enabled, but that it should be the default.  Obviously, though, 
you'll want to do testing on more than two machines before building that 


More information about the questions mailing list