[ntp:questions] Re: xntpd woes on non-global Solaris 10 zone

Brian Utterback brian.utterback at sun.removeme.com
Wed Dec 21 17:27:41 UTC 2005


cedricmarvin at yahoo.com wrote:
>   Hello,
> 
>   I am working with a Solaris 10 system with "zones" setup and I have
> been tasked with getting xntpd running in a non-global (not zone 0)
> zone which can't make ntp_adjtime system calls because its not zone 0.
>   Why is this happening ?  Consolidation of legacy servers and the
> primary admin of this Solaris 10 system does not want to put the legacy
> dns server (which was on a standalone Sparc 5 box) into zone 0 as a
> virtual network interface.
>   The Zone 0 part of this Solaris 10 box is talking ntp to an external
> server over it's network interface, so the system clock is okay.
> 
>   So, I just want the xntpd in the non-global zone to listen for
> network connections and hand out whatever it has for the time (which is
> the Zone 0 time which is ntp sync'd).
> 
>   The system is running xntpd 3-5.93e+sun which came with Solaris 10
> 
>   In ntp.conf I have:
> 
>    server 127.127.1.0
>    fudge 127.127.1.0 stratum 0
> 
>   But even though it is using the local clock, /var/adm/messages keeps
> saying:
> 
>    Dec 20 14:02:55 dns01 xntpd[5380]: [ID 373468 daemon.error]
>      adj_frequency: ntp_adjtime failed: Not owner
>    Dec 20 14:08:15 dns01 last message repeated 5 times
> 
>   I looked in the source for xntpd 3-5.93e and it seems that even if
> you have the local clock as primary, it still wants to make the
> ntp_adjtime system call.
> 
>   A couple of questions:
>    - Any way to stop the ntp_adjtime via some config parameter ?
>    - Do newer versions of xntpd also have this issue ?
> 
>   I'll put in a newer ntp daemon, but the in brave new world of Solaris
> 10 services I'm not totally confortable doing this (but I guess I have
> to get bloody at some point).
> 
>   Thanks in advance for any advice and help !
> 
>   - Cedric
> 


There really isn't any way to do this cleanly with the stock xntpd
in Solaris 10. Even if you put in "disable pll", xntpd will just
try to use the adjtime call instead of the ntp_adjtime call.

Your best bet is to use the latest ntpd version 4. With that, you
can use "disable ntp" and use the local refclock to get what you
want.

It should be relatively easy to add a new SMF start method for
ntpd.

-- 
blu

"Having them stolen may become our distribution model..."
Nicolas Negroponte on the Hundred Dollar Laptop.
----------------------------------------------------------------------
Brian Utterback - OP/N1 RPE, Sun Microsystems, Inc.
Ph:877-259-7345, Em:brian.utterback-at-ess-you-enn-dot-kom




More information about the questions mailing list