[ntp:questions] Re: xntpd woes on non-global Solaris 10 zone

cedricmarvin at yahoo.com cedricmarvin at yahoo.com
Thu Dec 22 20:40:31 UTC 2005


  Thank you Ronan and Brian for your replies.

  As Brian stated:
>There really isn't any way to do this cleanly with the stock xntpd
>in Solaris 10. Even if you put in "disable pll", xntpd will just
>try to use the adjtime call instead of the ntp_adjtime call.

  I found this to be the case.

  I got a binary distribution of ntp 4.2.0 and installed it in
/usr/local and then moved the ntp and xntp binaries that came with
Solaris 10 to <name>.old and did things like:
    ln -s /usr/local/bin/ntpd /usr/lib/inet/xntpd
  I also had to do an ln -s /etc/inet/ntp.conf /etc/ntp.conf because
that's where the binary wanted to find the configuration file.
  I did all this in zone 0, then in the non-global zone ntp.conf I
added "disable ntp"
  I didn't touch any of the SMF xml files.

  After a svcadm enable ntp on the global (real) and non-global
(handing out time only), all is well.
  The only minor glitch is that on startup this line was in
/var/adm/messages on the non-global zone:
Dec 22 12:07:18 dns01 xntpd[25993]: [ID 702911 daemon.error]
mlockall(): Not owner
  But at least there are no failed adjtime or ntp_adjtime calls being

  Thanks for all your help !

  - Cedric

More information about the questions mailing list