[ntp:questions] problem getting ATOM driver to work when compileing from source (long)

dave morgan morgad at eclipse.co.uk
Sat Jan 29 20:36:38 UTC 2005


I have been attempting to get the PPS going from my GPS unit
(Garmin GPS25HLV) - as the NEMA drive gives crap results
(jitter of over 50!)

I compiled and installed a 2.4.29 kernel, to make sure the
machine worked with my config choices

I then applied the new PPS patchkit to it (*thank you Ulrich*), made
oldconfig, chose all the PPS options and recompiled/rebooted

daemon.log -
ntpd[6179]: ntpd 4.2.0 at 1.1161-r Sat Jan 29 20:03:20 GMT 2005 (3)
ntpd[6179]: signal_no_reset: signal 13 had flags 4000000
ntpd[6179]: precision = 1.000 usec
ntpd[6179]: no IPv6 interfaces found
ntpd[6179]: kernel time sync status 2040
ntpd[6179]: refclock_atom: time_pps_create failed: Invalid argument
ntpd[6179]: configuration of 127.127.22.0 failed
ntpd[6179]: frequency initialized 88.848 PPM from /etc/ntp/driftfile
-----------seperator-------------
ntp.conf (in part) -
#msf rx on serial port 1
server 127.127.28.0 prefer
fudge 127.127.28.0  time1 0.022  refid MSF

#gps rx on serial port 0 - pps gives *MUCH* better jitter figure
#server 127.127.20.0 mode 2
#fudge 127.127.20.0 stratum 6 time1 .65
# flag3 1

enable stats monitor pps
#pps source
server 127.127.22.0
fudge  127.127.22.0 stratum 6
-----------seperator-------------
what have I got wrong? why does the ATOM diver fail to start?
something wrong with my kernel, or with my ntp compile?

uname -a now gives
Linux webserver 2.4.29-NANO #3 Sat Jan 29 18:55:09 GMT 2005 i686
unknown

I then untared a fresh copy of the ntp-4.2.0 source and ./configure
then make and make install, then kill and restart ntpd

ntpq -c rv shows
status=0964 leap_none, sync_telephone, 6 events, event_peer/strat_chg,
version="ntpd 4.2.0 at 1.1161-r Sat Jan 29 20:03:20 GMT 2005 (3)",
processor="i686", system="Linux/2.4.29-NANO", leap=00, stratum=1,
precision=-20, rootdelay=0.000, rootdispersion=4.299, peer=63629,
refid=MSF, reftime=c5a66f5f.3238a7e7  Sat, Jan 29 2005 20:23:59.196,
poll=6, clock=c5a66f8e.1887229e  Sat, Jan 29 2005 20:24:46.095,
state=4,
offset=-0.530, frequency=88.818, jitter=0.195, stability=0.003,
access_policy="Access via *.pool.ntp.org only, do not exceed 150
queries/hour"
-----------seperator-------------
ntptime gives
ntp_gettime() returns code 0 (OK)
  time c5a66fcd.8d758dec  Sat, Jan 29 2005 20:25:49.552, (.552575834),
  maximum error 26599 us, estimated error 194 us, TAI offset
-1073742472
ntp_adjtime() returns code 0 (OK)
  modes 0x0 (),
  offset -539.000 us, frequency 88.816 ppm, interval 4 s,
  maximum error 26599 us, estimated error 194 us,
  status 0x2001 (PLL,NANO),
  time constant 6, precision 1.181 us, tolerance 496 ppm,
  pps frequency 88.847 ppm, stability 0.000 ppm, jitter 0.000 us,
  intervals 0, jitter exceeded 0, stability exceeded 0, errors 0.
9
-----------seperator-------------
gps and pps both point to the same port, and the GPS worked
lrwxrwxrwx    1 root     root           10 Nov 20 16:10 gps0 ->
/dev/ttyS1
lrwxrwxrwx    1 root     root           10 Dec 10 21:29 pps0 ->
/dev/ttyS1

the machine is Debian Linux

webserver:/home/david/temp/ntp-4.2.0# ./config.guess
i686-pc-linux-gnu


Dave
-- 
http://www.morgad.no-ip.info/index.html    gpg:0x64B5E037 
Distributed Proofreaders: http://www.pgdp.net
The NTP server pool http://www.pool.ntp.org



More information about the questions mailing list