Using BIND - was Re: [ntp:questions] Re: How long doI havetowaitfor sync?

Danny Mayer mayer at gis.net
Sun Jun 5 00:32:44 UTC 2005


At 04:18 PM 6/4/2005, David J Taylor wrote:
>mayer wrote:
> > ----- Original Message Follows -----
> >> Well, thanks to Danny, Brad and David I have this working.  Danny may
> >> wish  to note:
> >>
> >> - it doesn't say anywhere in the Windows ReadMeFirst to create the
> >> file  named.conf - perhaps an empty one should be supplied in the
> >> correct  directory?
> >>
> > I don't want to do that as there's too much risk of overwriting an
> > existing one.
>
>If FileExists ('named.conf') skip creation?

I always hesitate to do this. At best I might provide and example that
you could move yourself.


> >> - the required directory \dns\etc\namedb is not automatically created
> >> (although there seem to be no files created there?).
> >>
> > That's optional in how you set up your zones. I don't bother with
> > a subdirectory as I don't have a lot of zones.
>
>Then it should be mentioned.

Mentioned where? The ARM tells you that the directory option makes all files
relative to the directory.

> >> - the \dns\etc directory needed to have its permissions changed (full
> >> control added for the named users) to allow named.pid to be created.
> >>
> > It's one of those unfinished business pieces in the installer.
> > If it's not in the readme I'll add it. Okay, it is in the readme.
>
>It isn't in readme1st.txt, where are you looking?

Which version of BIND did you install? I looked at the 9.3.1 readme1st.txt
and it's in there. I was very careful to document that fact. The second
paragraph of "Important Kit Installation Information" tells you this.

> > Note that named.pid is not really essential for windows as nothing
> > uses it.
>
>Well, the server creates it, and doesn't work without it.  Not quite sure
>how that is "not essential".

Not essential for tools outside of BIND. Sorry if you misunderstood that
statement. You can use the following statement within options {}
to stop named creating a pid file:
pid-file none;


>Cheers,
>David




More information about the questions mailing list