[ntp:questions] clock not synching with low stratum time server

Sankaran Balaji balajisa at india.hp.com
Fri Jun 17 13:17:07 UTC 2005


Hi,

I have a configuration which i have pasted below in ntp.conf

server 127.127.1.0 version 3

fudge 127.127.1.0 stratum 12

server timeclripfa.akadns.net version 3

peer cla2astr version 3

peer cla3astr version 3

peer cla4astr version 3


If i run my xntpd(4.1.1) daemon with the above configuration, i found
that after some time clock syncs with the local clock or other
peer servers(  cla2astr-ics0, cla3astr-ics0 and cla4astr-ics0 )
which have a very high stratum value (12). The  server
timeclripfa.akadns.net has a stratum value of 2. I believe
that xntpd should choose a low stratum server as its time source.
I ran ntpdate timeclripfa.akadns.net before starting xntpd.

Is there any reason why xntpd does not choose the low startum server
and falls back on local clock for synchronization ?

I ran xntpd in debug mode ( immediately after running ntpdate with
timeclripfa.akadns.net) and found that the initial offset difference
immediately goes up to  around 174ms.. This value keeps increasing to
more than +100secs and my system doesnot sync at all..


Thanks,
Balaji





More information about the questions mailing list