[ntp:questions] Optimizing ntpd memory usage?

David Wuertele dave-gnus at bfnet.com
Mon May 16 18:49:20 UTC 2005


I'm using ntpd in an embedded Linux system, just to discipline my own
local clock.  Many of my third party developers are complaining to me
about the ntpd process's memory usage.  Top is showing me RSS=3404
SHARED=2988, and when I run ntpd for the first time I'm seeing free
memory drop by 1.93MB.

I don't know why NTP should take almost 2MB for my simple
configuration.  I disable most of the drivers.  Here is my configure
invocation:

./configure --build=i386-pc-linux-gnu --target=mipsel-linux --host=mipsel-linux --disable-ACTS --disable-ACTS --disable-ARBITER --disable-ARCRON-MSF --disable-AS2201 --disable-ATOM --disable-CHRONOLOG --disable-CHU --disable-AUDIO-CHU --disable-DATUM --disable-DUMBCLOCK --disable-FG --disable-HEATH --disable-HOPFSERIAL --disable-HOPFPCI --disable-HPGPS --disable-IRIG --disable-JJY --disable-JUPITER --disable-LEITCH --disable-LOCAL-CLOCK --disable-MSFEES --disable-MX4200 --disable-NEOCLOCK4X --disable-NMEA --disable-ONCORE --disable-PALISADE --disable-PCF --disable-PST --disable-PTBACTS --disable-RIPENCC --disable-SHM --disable-SPECTRACOM --disable-TPRO --disable-TRAK --disable-TRUETIME --disable-TT560 --disable-ULINK --disable-USNO --disable-WWV --disable-ZYFER --disable-COMPUTIME --disable-DCF7000 --disable-HOPF6021 --disable-MEINBERG --disable-RAWDCF --disable-RCC8000 --disable-SCHMID --disable-TRIMTAIP --disable-TRIMTSIP --disable-WHARTON --disable-VARITEXT --disable-audio --without-crypto --program-prefix=

Here is my ntp.conf:

  server <server address>
  disable monitor
  restrict default nopeer

Can anyone recommend steps I can take to reduce ntpd's memory
requirement?

Thanks,
Dave



More information about the questions mailing list