[ntp:questions] Re: ntpd remains in state 3 and stratum 16

Richard B. Gilbert rgilbert88 at comcast.net
Thu Nov 10 03:23:37 UTC 2005


mail at iceberg.pl wrote:

> <>Hi.
> My problem seem to be quite common as I found several similar posts on
> this group and on many other places, but I still cannot find the
> solution for myself.
> After several minutes (15-20) my ntpd still does not want to
> synchronize.
> Here comes the details:
> I am using ntpd 4.2.0a on a Linux SMP box (kernel 2.4.22). This is
> Debian Testing, with ntpd from the Debian package. I also tried to
> compile ntpd by myself widh --enable-debugging option.
> The output of "ntpq -crv -p" looks as follows:
>
> #v+
> assID=0 status=c624 sync_alarm, sync_ntp, 2 events,
> event_peer/strat_chg,
> version="ntpd 4.2.0a at 1:4.2.0a+stable-2-r Wed Nov 9 18:22:44 CET 2005
> (1)"?,
> processor="i686", system="Linux/2.4.22", leap=11, stratum=16,
> precision=-14, rootdelay=0.000, rootdispersion=5.190, peer=29428,
> refid=INIT, reftime=00000000.00000000 Thu, Feb 7 2036 7:28:16.000,
> poll=6, clock=0xc71cb85f.c3d60e94, state=3, offset=66.683,
> frequency=0.000, noise=33.342, jitter=13.651, stability=0.000
> remote refid st t when poll reach delay offset
> jitter
> ==============================================================================
> *vega.cbk.poznan .PPS. 1 u 23 64 77 43.250 66.683
> 10.310
> +info.cyf-kr.edu 131.188.3.221 2 u 21 64 77 54.562 74.754
> 16.954
> +smtp.certum.pl .GPS. 1 u 24 64 77 43.749 77.732
> 14.420
> +tick.informatik 130.149.17.21 2 u 18 64 57 81.965 82.170
> 13.794
> +adm.active24.cz 193.204.114.232 2 u 19 64 77 63.208 79.791
> 60.361
> LOCAL(0) LOCAL(0) 13 l 14 64 77 0.000 0.000
> 0.061
> <snip>
> Could You please tell me what am I doing wrong? How can I get my ntpd
> working?
>
The ntpq output shows that all your servers are reachable, and that each 
server has responded to the last six requests (reach field = 77).  This 
suggests that ntpd has been running for only a little over six minutes 
at this point.   "vega.cbk.poznan" has been selected as synchronization 
source.  The five external servers all show offsets in the range 67 to 
82 milliseconds which suggests that you did not start ntpd with the -g 
option nor did you set the clock with ntpdate before starting ntpd (not 
required but generally helpful).

Suggestions:
1.  Start ntpd with the -g option.  This will cause ntpd to set the 
clock to its best guess as to the correct time before starting the 
process of synchronization.  People used to do this with ntpdate which 
is now deprecated.
2.  Use the "iburst" keyword in each server statement.  This will cause 
ntpd to send the first eight requests to each server at two second 
intervals.   This gives ntpd enough information to start synchronizing 
your clock in the first ten seconds or so instead of the first five minutes.
3.  Comment out any restrict statements in ntp.conf until you get 
everything else working.
4.  If you still need help, post your ntp.conf file and the output of 
ntpq -p taken at least ten minutes after starting ntpd.




More information about the questions mailing list