[ntp:questions] Re: Clock skew too great

Richard B. Gilbert rgilbert88 at comcast.net
Fri Nov 11 21:16:27 UTC 2005


Sabrina Lautier wrote:

>All,
>
>I've got time skew errors on all HP DL385 servers with 2 network cards
>configured.
>This issue only occurs on this specific hardware - it does not on our HP
>DL145.
>And yet the Linux distribution is the same (SuSe SLES9 AMD64) and so is the
>ntp package and configuration.
>On a HP DL385 if only 1 network card is configured this issue does not
>exist.
>
># On an HP DL385
>$ uname -a
>Linux dl385_linux 2.6.5-7.151-smp #1 SMP Fri Mar 18 11:31:21 UTC 2005
>x86_64 x86_64 x86_64 GNU/Linux
>
># On an HP DL145
>$ uname -a
>Linux dl145_linux 2.6.5-7.155.29-smp #1 SMP Thu Jun 2 12:07:05 UTC 2005
>x86_64 x86_64 x86_64 GNU/Linux
>
># On both hardware
>$ rpm -q xntp
>xntp-4.2.0a-23.4
>
>$ cat /etc/ntp.conf
>
>##
>## Outside source of synchronized time
>##
>## server xx.xx.xx.xx           # IP address of server
>
>##
>## Miscellaneous stuff
>##
>
>driftfile /var/lib/ntp/drift/ntp.drift # path for drift file
>
>logfile /var/log/ntp            # alternate log file
>server ntp1.nce.amadeus.net
>server ntp2.nce.amadeus.net
>server ntp3.nce.amadeus.net
># logconfig =syncstatus + sysevents
># logconfig =all
>
># statsdir /tmp/                # directory for statistics files
># filegen peerstats  file peerstats  type day enable
># filegen loopstats  file loopstats  type day enable
># filegen clockstats file clockstats type day enable
>
>#
># Authentication stuff
>#
># keys /etc/ntp.keys            # path for keys file
># trustedkey 1 2 3 4 5 6 14 15  # define trusted keys
># requestkey 15                 # key (7) for accessing server variables
># controlkey 15                 # key (6) for accessing server variables
>
>The network cards are not the same:
>DL385: Compaq NC7782 Gigabit Server Adapter
>DL145: AMD NetXtreme BCM5704 Gigabit Ethernet
>
>This issue if very annoying as services like winbind and cvs does not work
>properly:
>
>$ grep skew /var/log/messages
>Nov  9 18:58:32 dl385_linux winbindd[2895]:   Kinit failed: Clock skew too
>great
>
>The only current work-around I found is to restart xntpd every minute in
>the crontab.
>
>Could you please help ?
>
>Thx a lot for your help.
>
>Rgds,
>Sabrina
>
>_______________________________________________
>questions mailing list
>questions at lists.ntp.isc.org
>https://lists.ntp.isc.org/mailman/listinfo/questions
>
>  
>
How large is the clock skew?  What is your kernel parameter "HZ" set 
to?  If it's set to 1000, try changing it to 100.




More information about the questions mailing list