[ntp:questions] ntpd local synchronization fails?

Danny Mayer mayer at ntp.isc.org
Tue Nov 15 03:03:46 UTC 2005


Wilhelm Greiner wrote:
> Hi,
> 
> i have an ntp multicast Client running, but it fails
> to synchronize his local clock, ntp as Service is
> running and delivering the right time. Only the
> local clock will not be set.
> 
> NTP Version 4.1.2 is running on Linux 2.6.12.
> I cant use ntpd Version 4.2.x, there is a multicast
> Client bug.
>

Not any more. Please upgrade to the latest ntp-dev snapshot. The fix
should be in there.

> 
> 
> It seems that the step is to big and the kernel fails, is that true?
> 

If the step is too big and you didn't start ntpd with the -g flag, ntpd
will exit.

> What can i do to force ntpd let the local clock synchronized?
> 

You don't synchronized to LOCAL, since that is by definition the same as
the local clock.

> 
> 
> [root at ntp log]# ntpq -p
>      remote           refid      st t when poll reach   delay   offset  jitter
> ==============================================================================
>  LOCAL(0)        LOCAL(0)         6 l   50   64  377    0.000    0.000   0.015
> *192.168.1.9     192.168.100.5    2 m    2   64  377    0.015  -21.714  16.686
> 
192.168.1.* is not a valid multicast address. You can only use valid
multicast addresses, though the system seems to be accepting it for
reasons that I cannot easily tell. Use a valid multicast address. For
IPv4 valid multicast addresses are in the range 224.0.0.0 to
239.255.255.255. That's what you need to use. Don't use Local unless you
are serving other systems from this one, it is unlikely to do what you
might think.

Danny



More information about the questions mailing list