[ntp:questions] Re: Garbage in Refid field - peers

Danny Mayer mayer at gis.net
Fri Nov 18 13:42:34 UTC 2005


TJ Horlacher wrote:
> "Danny Mayer" <mayer at gis.net> wrote in message 
> news:437D5060.1000303 at gis.net...
> 
>>TJ Horlacher wrote:
>>
>>>"Danny Mayer" <mayer at gis.net> wrote in message
>>>news:437D3865.9050408 at gis.net...
>>>
>>>
>>>>TJ Horlacher wrote:
>>>>
>>>>
>>>>>When doing a ntpq -p, I am getting garbage in the refid column from
>>>>>Windows
>>>>>servers. Happens when running ntpq from Linux or Windows, but if garbage
>>>>>is
>>>>>there, than it is always coming from a Windows ntp server.
>>>>>
>>>>>sv1.time.com     204.17.42.199      11 u    15    64    377    0.001
>>>>>242.768   4.142
>>>>>sv2.time.com     .Ñ                         16 u    25    512    0
>>>>>0.000
>>>>>0.000 4000.00
>>>>>
>>>>>Linux servers running ntp v4.2.0.a.20040617-8
>>>>>Windows servers running ntp v4.2.0b at 20051016
>>>>>
>>>>>Any advise, outside of don't run ntp on windows...
>>>>>
>>>>
>>>>On the contrary, upgrade ntp on Linux. This bug was fixed a long time
>>>>ago in the development stream.
>>>>
>>>>Danny
>>>>
>>>
>>>
>>>Danny thanks for the reply,
>>>
>>>I may try that, but this is also happening when running ntpq from windows
>>>server console as well. Stating that, also keep in mind the gabage in the
>>>refid field is only coming from windows server peers. I would think if it 
>>>is
>>>an ntp issue on linux, then I would only beeing seeing this problem when
>>>running ntpq on linux consoles.
>>>
>>>I had previously reviewed ntp.org bug list, and you are correct - there 
>>>is a
>>>listing that is new for Solaris and regarding 4.2.0b. However, I was 
>>>hoping
>>>someone may have found a root cause or workaround.
>>>
>>>https://ntp.isc.org/bugs/show_bug.cgi?id=221
>>>
>>
>>Oh that one. Yes, I haven't had time to look at it. Debugging it is ugly
>>and reproducing it may be harder.
>>
> 
> 
> FYI: downgraded one of the Windows servers to ntp version 4.0.2a.1.1370 and 
> am no longer getting garbage in the reif column. Still getting garbage from 
> win servers using 4.0.2b but not 4.0.2a... I will downgrade the other win 
> servers tomorrow, unless some additional light is posted on the subject.
> 
> Mybe this will shed some light during debug.
> 
> TJ Horlacher
> 
Please add this information to the bug item so we don't lose it.

Thanks,

Danny



More information about the questions mailing list