[ntp:questions] Issue with Canadian NTP Pools

IceWookie at gmail.com IceWookie at gmail.com
Tue Nov 22 15:41:59 UTC 2005


I'm running a bunch of Solaris 9 boxes as NTP servers, using the
various Canadian NTP servers defined by #.ca.pool.ntp.org.  But the
problem I'm having is that the values are for the same server.  Am I
the only one seeing this??

root @ /> ntpq -pn
     remote           refid      st t when poll reach   delay   offset
jitter
==============================================================================
 64.235.218.180  .STEP.          16 u    - 1024    0    0.000    0.000
4000.00
 64.235.218.180  .STEP.          16 u    - 1024    0    0.000    0.000
4000.00
*64.235.218.180  199.212.17.15    3 u  575 1024  377   20.886    0.531
 0.490


My DNS servers resolves the various entries as follows:

root @ /> nslookup 0.ca.pool.ntp.org
Server:  dns.server.ca
Address:  xxx.xxx.xxx.xxx

Non-authoritative answer:
Name:    0.ca.pool.ntp.org
Addresses:  64.235.218.180, 66.11.161.129, 66.96.25.75, 66.96.30.35
          66.96.30.91, 66.96.30.99, 136.159.2.2, 142.179.100.217,
207.61.229.70
          207.245.43.147, 216.194.70.2, 216.221.85.101, 216.234.161.11,
216.252.70.172

root @ /> nslookup 1.ca.pool.ntp.org
Server:  dns.server.ca
Address:  xxx.xxx.xxx.xxx

Non-authoritative answer:
Name:    1.ca.pool.ntp.org
Addresses:  216.252.70.172, 64.235.218.180, 66.11.161.129, 66.96.25.75
          66.96.30.35, 66.96.30.91, 66.96.30.99, 136.159.2.2,
142.179.100.217
          207.61.229.70, 207.245.43.147, 216.194.70.2, 216.221.85.101,
216.234.161.11

root @ /> nslookup 2.ca.pool.ntp.org
Server:  dns.server.ca
Address:  xxx.xxx.xxx.xxx

Non-authoritative answer:
Name:    2.ca.pool.ntp.org
Addresses:  64.235.218.180, 66.11.161.129, 66.96.25.75, 66.96.30.35
          66.96.30.91, 66.96.30.99, 136.159.2.2, 142.179.100.217,
207.61.229.70
          207.245.43.147, 216.194.70.2, 216.221.85.101, 216.234.161.11,
216.252.70.172


And ntp.conf:
root @ /> cat /etc/inet/ntp.conf
server 0.ca.pool.ntp.org
server 1.ca.pool.ntp.org
server 2.ca.pool.ntp.org

driftfile /var/ntp/logs/ntp.drift
logfile /var/ntp/logs/ntp.log
statsdir /var/ntp/stats/

filegen peerstats file peer.stats type day enable
filegen loopstats file loop.stats type day enable
filegen clockstats file clock.stats type day enable


Any ideas what I can do to fix this??  Thanks in advance.

Andy




More information about the questions mailing list