[ntp:questions] more linux porting problems

Danny Mayer mayer at gis.net
Wed Oct 5 03:00:15 UTC 2005


Chris Richmond - MD6-FDC ~ wrote:
> Hi Folks,
> 
>    I downloaded the 4.2.0b release and tried to compile it on
> three different systems at home (no wise cracks) and was unsuccessful
> for more or less the same reason on all three.  I ran .configure
> turning off IPV6 support that no errors were reported.
> 
We have fixed a bunch problems like this in the development stream. You 
should try picking up the latest development version and build that.

People make the mistake of thinking that turning off IPv6 support will 
fix build problems relating to IPv6. That's a mistaken assumption. It 
won't. It has nothing to do with whether or not you have an IPv6 stack.

> make failed with a syntax error in stdarg.h.  The block its having
> a problem with looks like this (with minor variations):
> 
> /* Define __gnuc_va_list.  */
> 
> #ifndef __GNUC_VA_LIST
> #define __GNUC_VA_LIST
> #if defined(__svr4__) || defined(_AIX) || defined(_M_UNIX) || defined(__NetBSD__)
> typedef char *__gnuc_va_list;
> #else
> typedef void *__gnuc_va_list;
> #endif
> #endif
> 
> The path is something like this (again, with variations with release):
> lib/gcc-lib/i686-pc-linux-gnu/2.95.3/include/stdarg.h
> 
> I tried on RedHat6.1, RedHat8, and Fedora Core4.  What am I missing?

You're missing the fact that you need the IPv6 structures in there even 
if you don't have IPv5 enabled.

Danny
> I saved the configure and make logs, so I can look for specific errors
> when I get home.
> 
> Thx, Chris
> 




More information about the questions mailing list