[ntp:questions] Use of the ppc->pps device for time keeping ? (FreeBSD 5.4)

Ken Stone ken at sdd.hp.com
Sat Oct 15 15:21:40 UTC 2005


I have an HP lp1000r server that I just loaded the FreeBSD 5.4 Production 
code onto ... everything works great other than I cannot get a /dev/pps0 
to appear.

At boot, I can see:

    ppc0: parallel port found at 0x378
    ppc0: using extended I/O port range
    PC873xx probe at 0x2e got unknown ID 0x0
    ppc0: SPP
    ppc0: <Standard parallel printer port> port 0x378-0x37f on acpi0
    ppc0: Generic chipset (NIBBLE-only) in COMPATIBLE mode
    ppbus0: <Parallel port bus> on ppc0
    pps0: <Pulse per second Timing Interface> on ppbus0
    device_attach: pps0 attach returned 6
    lpt0: <Printer> on ppbus0
    lpt0: Polled port

No matter what mode I put the parallel port in via the BIOS config, I
get roughly the same result ... The pps interface does not come up
due to there being no IRQ associated with ppc0 ?

The BIOS definately says that the parallel port is at IRQ 7 and nothing 
else uses IRQ 7 ... Tried it at IRQ 5 shared with the USB controller
and it made no difference.

Any help appreciated

Thanks

  -- Ken




More information about the questions mailing list