[ntp:questions] Re: Use of the ppc->pps device for time keeping ? (FreeBSD 5.4)

rtxo gnu at wraith.sf.ca.us
Thu Oct 20 03:47:25 UTC 2005


Ken Stone wrote:
> I have an HP lp1000r server that I just loaded the FreeBSD 5.4 Production 
> code onto ... everything works great other than I cannot get a /dev/pps0 
> to appear.

Theres always...

# cd /dev
# rm -f pps0
# ./MAKEDEV pps0

You might need to recreate this after every reboot, since 5.x wipes clean
/dev everytime it comes up.

> At boot, I can see:

(stuff)

> No matter what mode I put the parallel port in via the BIOS config, I
> get roughly the same result ... The pps interface does not come up
> due to there being no IRQ associated with ppc0 ?
> 
> The BIOS definately says that the parallel port is at IRQ 7 and nothing 
> else uses IRQ 7 ... Tried it at IRQ 5 shared with the USB controller
> and it made no difference.

Look at the interrupt count with vmstat -i and see if irq7 bumps.
I've run the PPS out of a Spectracom netclock/2 with the parallel
port and it works well, though I was using an earlier 5.x.

../Steven




More information about the questions mailing list