[ntp:questions] Use of the ppc->pps device for time keeping ? (FreeBSD 5.4)

Mauro Fiacco Mauro.Fiacco at ipaccess.com
Thu Oct 20 09:55:51 UTC 2005


You are almost there.... We were wondering about the same thing a week

The trick was to create a simlink from /dev/pps0 to /dev/cuaa0
(ln -s /dev/cuaa0 /dev/pps0)

If you use the pps-api utility (in the standard NTP distribution under

>> pps-api /dev/cuaa0

you should see things like:

1129798342.343573122 1129798342.143589753 495288 495289 -0.199983369
1129798342.343573122 1129798343.143588740 495288 495290 0.800015618
1129798343.343574722 1129798343.143588740 495289 495290 -0.199985982

which is your PPS signal!

Rememeber to enable the pps on the ntp.conf (enable pps), and the atom
refclock be configured when compiling  ntp.

If your PPS signal is unsynchronised (e.g. is taken from a rubidium
source), you'll need to tell the kernel to only use FLL not PLL. In
theory it would be enough to set the stratum to undefined (aka 16) but
it won't work (I think is a bug in the code, but it seems that the
stratum is not initialised). You'll have to comment out the line which
sets the STA_PLL in ntp_loopfilter (see Dave Mill mail of few days ago)

Hope it will work for you!



On Sat, Oct 15, 2005 at 08:21:40AM -0700, Ken Stone wrote:
> Date: 15 Oct 2005 08:21:40 -0700
> From: Ken Stone <ken at sdd.hp.com>
> To: questions at lists.ntp.isc.org
> Subject: [ntp:questions] Use of the ppc->pps device for time keeping ?
> 	(FreeBSD 5.4)

> I have an HP lp1000r server that I just loaded the FreeBSD 5.4 Production 
> code onto ... everything works great other than I cannot get a /dev/pps0 
> to appear.

> At boot, I can see:

>     ppc0: parallel port found at 0x378
>     ppc0: using extended I/O port range
>     PC873xx probe at 0x2e got unknown ID 0x0
>     ppc0: SPP
>     ppc0: <Standard parallel printer port> port 0x378-0x37f on acpi0
>     ppc0: Generic chipset (NIBBLE-only) in COMPATIBLE mode
>     ppbus0: <Parallel port bus> on ppc0
>     pps0: <Pulse per second Timing Interface> on ppbus0
>     device_attach: pps0 attach returned 6
>     lpt0: <Printer> on ppbus0
>     lpt0: Polled port

> No matter what mode I put the parallel port in via the BIOS config, I
> get roughly the same result ... The pps interface does not come up
> due to there being no IRQ associated with ppc0 ?

> The BIOS definately says that the parallel port is at IRQ 7 and nothing 
> else uses IRQ 7 ... Tried it at IRQ 5 shared with the USB controller
> and it made no difference.

> Any help appreciated

> Thanks

>   -- Ken

> _______________________________________________
> questions mailing list
> questions at lists.ntp.isc.org
> https://lists.ntp.isc.org/mailman/listinfo/questions

Mauro Fiacco 

ip.access Ltd                      
URL: www.ipaccess.com  

More information about the questions mailing list