[ntp:questions] Re: Is ntp working?

Richard B. Gilbert rgilbert88 at comcast.net
Fri Oct 21 16:35:48 UTC 2005


Steven Meres wrote:

>Martin Burnicki wrote:
>
>  
>
>>Have a look at the process IDs in the log messages. 
>>You have at least 2 ntpds running. I'd suggest to kill all ntpd processes
>>first, then start a new one.
>>    
>>
>
>Thank you for the response.  I did check which processes I had running and
>there were actually 3 instances of ntpd running.  I killed them all then
>restarted ntpd.
>
>Richard B. Gilbert wote:
>
>  
>
>>Well, through bad luck or poor design,  you have servers in the 
>>Netherlands, Australia and, I think, in the US.
>>    
>>
>
><snip>
>
>  
>
>>Try posting your ntp.conf file and the output of ntpq -p after ntp has 
>>been running for at least fifteen or twenty minutes (more is better).   
>>Also post the output of ntpq -c version which should tell us what 
>>version of ntpd we are dealing with.
>>    
>>
>
>I looked at my ntp.conf and deleted the entry describing the current pool. I
>replaced the pool with a listing of sites closer to me.
>Between you reply and the reply from Martin I believe everything is working.
>Following are the results of my ntp.conf, ntpq - p, and ntpq - c.  Thanks
>again!
>
># /etc/ntp.conf, configuration for ntpd
>
># ntpd will use syslog() if logfile is not defined
>logfile /var/log/ntpd
>
>driftfile /var/lib/ntp/ntp.drift
>statsdir /var/log/ntpstats/
>
>statistics loopstats peerstats clockstats
>filegen loopstats file loopstats type day enable
>filegen peerstats file peerstats type day enable
>filegen clockstats file clockstats type day enable
>
>
># You do need to talk to an NTP server or two (or three).
>
>
>server ntp0.cornell.edu
>server clock.tricity.wsu.edu
>server louie.udel.edu
>server ntp1.cmc.ec.gc.ca
>server ntp2.cmc.ec.gc.ca
>server 127.127.1.0
>fudge 127.127.1.0 stratum 10
>
># By default, exchange time with everybody, but don't allow configuration.
># See /usr/share/doc/ntp-doc/html/accopt.html for details.
>
>restrict default kod notrap nomodify nopeer noquery
>
># Local users may interrogate the ntp server more closely.
>
>restrict 127.0.0.1 nomodify
>
>fserver:~# ntpq -p
>     remote           refid      st t when poll reach   delay   offset
>jitter
>============================================================================
>==
>+cudns.cit.corne 192.43.244.18    2 u   13  128  377   39.608  136.478
>96.965
>-louie.udel.edu  18.145.0.30      2 u   14  128  377  112.750   84.302
>12.961
>+wxo-svr1.cmc.ec 18.145.0.30      2 u    4  128  377   58.473  124.447
>18.808
>*wxo-svr2.cmc.ec 18.26.4.105      2 u   75  128  377   57.306  121.923
>71.644
> LOCAL(0)        LOCAL(0)        10 l   13   64  377    0.000    0.000
>0.001
>fserver:~# ntpq -c version
>ntpq 4.2.0a at 1:4.2.0a+stable-2-r Fri Aug 26 10:57:27 UTC 2005 (1)
>fserver:~#
>
>
>_______________________________________________
>questions mailing list
>questions at lists.ntp.isc.org
>https://lists.ntp.isc.org/mailman/listinfo/questions
>
>  
>
Your are running with some very large offsets!  That suggests that 
either you started with a large offset and ntpd has not been running 
very long or that you still have problems.  I would expect the offsets 
to be less than twenty, or even ten, milliseconds.

If you use the iburst keyword in your server statements, ntpd should 
send the first eight queries at two second intervals.   This allows ntpd 
to gather enough information to set the clock (if you started with the 
-g option) and begin synchronizing it within the first sixteen seconds.  
If you are cold starting the system ntpd may need several hours to 
achieve really tight synchronization.




More information about the questions mailing list