[ntp:questions] Re: time reset, syncronisation lost and Large PPM values

Richard B. Gilbert rgilbert88 at comcast.net
Fri Oct 21 19:59:46 UTC 2005


tor wrote:

>Something bothers  ntpd so it looses sync about every half hour.
>The messages from two versions of ntpd are given below.
>
>What is going on here and what can I do about it?
>
>Running RHEL3 on Dell PowerEdge 2600.
>$uname -a: Linux srv3 2.4.21-9.0.3.ELsmp #1 SMP Mon May 3 13:49:17 WEST 2004
>i686 i686 i386 GNU/Linux
>
>Similar behaviour is also seen on a HP box running RHEL3.
>
>First the stock ntpd:
>
>Oct 19 17:19:09 srv3 ntpd[19356]: ntpd 4.1.2 at 1.892 Wed Oct 19 17:18:24 WEST
>2005 (1)
>Oct 19 17:19:09 srv3 ntpd[19356]: precision = 7 usec
>Oct 19 17:19:09 srv3 ntpd[19356]: kernel time discipline status 0040
>Oct 19 17:19:09 srv3 ntpd[19356]: frequency initialized 500.000 from
>/var/lib/ntp/drift
>Oct 19 17:19:09 srv3 ntpd: ntpd startup succeeded
>Oct 19 17:22:33 srv3 ntpd[19356]: kernel time discipline status change 41
>Oct 19 17:23:36 srv3 ntpd[19356]: kernel time discipline status change 1
>Oct 19 17:37:36 srv3 ntpd[19356]: time reset 0.256144 s
>Oct 19 17:37:36 srv3 ntpd[19356]: synchronisation lost
>Oct 19 18:00:11 srv3 ntpd[19356]: time reset 0.239413 s
>Oct 19 18:00:11 srv3 ntpd[19356]: synchronisation lost
>
>Then I tried with a more recent version of ntpd (and started with -g)
>
>Oct 20 15:37:12 srv3 ntpd[20655]: ntpd 4.2.0 at 1.1161-r Thu Oct 20 14:07:07
>WEST 2005 (1)
>Oct 20 15:37:12 srv3 ntpd[20655]: precision = 1.000 usec
>Oct 20 15:37:12 srv3 ntpd[20655]: no IPv6 interfaces found
>Oct 20 15:37:12 srv3 ntpd[20655]: kernel time sync status 0040
>Oct 20 15:37:13 srv3 ntpd[20655]: frequency initialized 500.000 PPM from
>/var/lib/ntp/drift
>Oct 20 15:40:31 srv3 ntpd[20655]: synchronized to LOCAL(0), stratum=10
>Oct 20 15:40:31 srv3 ntpd[20655]: kernel time sync disabled 0041
>Oct 20 15:41:34 srv3 ntpd[20655]: kernel time sync enabled 0001
>Oct 20 15:45:48 srv3 ntpd[20655]: synchronized to 84.16.227.206, stratum=3
>Oct 20 15:45:49 srv3 ntpd[20655]: synchronized to 81.7.132.92, stratum=2
>Oct 20 15:45:53 srv3 ntpd[20655]: synchronized to 200.23.51.205, stratum=1
>Oct 20 15:54:28 srv3 ntpd[20655]: frequency error 502 PPM exceeds tolerance
>500 PPM
>Oct 20 16:07:10 srv3 ntpd[20655]: synchronized to 217.114.97.97, stratum=2
>Oct 20 16:09:27 srv3 ntpd[20655]: synchronized to 200.23.51.205, stratum=1
>Oct 20 16:09:31 srv3 ntpd[20655]: time reset +0.683516 s
>Oct 20 16:09:31 srv3 ntpd[20655]: frequency error 502 PPM exceeds tolerance
>500 PPM
>Oct 20 16:13:47 srv3 ntpd[20655]: synchronized to LOCAL(0), stratum=10
>Oct 20 16:13:47 srv3 ntpd[20655]: frequency error 502 PPM exceeds tolerance
>500 PPM
>Oct 20 16:14:51 srv3 ntpd[20655]: frequency error 502 PPM exceeds tolerance
>500 PPM
>Oct 20 16:15:57 srv3 ntpd[20655]: frequency error 502 PPM exceeds tolerance
>500 PPM
>Oct 20 16:17:01 srv3 ntpd[20655]: frequency error 502 PPM exceeds tolerance
>500 PPM
>Oct 20 16:18:06 srv3 ntpd[20655]: frequency error 502 PPM exceeds tolerance
>500 PPM
>Oct 20 16:19:11 srv3 ntpd[20655]: synchronized to 217.114.97.97, stratum=2
>Oct 20 16:19:14 srv3 ntpd[20655]: synchronized to 200.23.51.205, stratum=1
>Oct 20 16:39:32 srv3 ntpd[20655]: synchronized to 81.7.132.92, stratum=2
>Oct 20 16:42:43 srv3 ntpd[20655]: synchronized to 200.23.51.205, stratum=1
>Oct 20 16:47:12 srv3 ntpd[20655]: synchronized to 217.114.97.97, stratum=2
>Oct 20 16:47:15 srv3 ntpd[20655]: synchronized to 200.23.51.205, stratum=1
>Oct 20 16:47:15 srv3 ntpd[20655]: time reset +0.803924 s
>Oct 20 16:51:34 srv3 ntpd[20655]: synchronized to LOCAL(0), stratum=10
>Oct 20 16:56:49 srv3 ntpd[20655]: synchronized to 213.144.132.251, stratum=2
>Oct 20 16:56:55 srv3 ntpd[20655]: synchronized to 200.23.51.205, stratum=1
>Oct 20 17:09:45 srv3 ntpd[20655]: synchronized to 217.114.97.97, stratum=2
>Oct 20 17:09:51 srv3 ntpd[20655]: synchronized to 200.23.51.205, stratum=1
>Oct 20 17:17:19 srv3 ntpd[20655]: time reset +0.713103 s
>Oct 20 17:21:41 srv3 ntpd[20655]: synchronized to LOCAL(0), stratum=10
>Oct 20 17:26:55 srv3 ntpd[20655]: synchronized to 81.7.132.92, stratum=2
>Oct 20 17:27:02 srv3 ntpd[20655]: synchronized to 200.23.51.205, stratum=1
>
>Oct 20 17:39:50 srv3 ntpd[20655]: synchronized to 81.7.132.92, stratum=2
>Oct 20 17:44:10 srv3 ntpd[20655]: synchronized to 200.23.51.205, stratum=1
>Oct 20 17:44:14 srv3 ntpd[20655]: time reset +0.600966 s
>
>
>  
>
Linux has a kernel parameter called, I believe HZ.   It can have values 
of 1000 or 100.   If set to 1000 the clock "ticks" 1000 times per second 
and the processor must service 1000 interrupts per second.  A system 
without very much else to do can handle this easily.   A busy system, 
OTOH, tends to lose clock interrupts.  If yours is set to 1000, try 
changing it to 100.

It's also possible that your clock really does have a frequency error in 
excess of 500 parts per million.  If this is the case, start by getting 
it fixed.  Typical  frequency errors are generally less than 50 PPM;
I have three Sun Ultra 10 workstations with frequency errors of 5.3, 
-2.714 and 5.873 PPM and a DEC Alphastation 200 4/233 with a frequency 
error of -32.91 PPM.  Four is a very small sample but I think it's 
suggestive!





More information about the questions mailing list