[ntp:questions] Re: w32tm DC error

Martin Burnicki martin.burnicki at meinberg.de
Mon Apr 10 14:08:44 UTC 2006

Ry wrote:

> That 0x1 after the host name looks strange; I see that documented in
> the KB article but it does not appear when I run w32tm /dumpreg on my
> own systems. 

As I understand the KB article below:

the flag 0x1 tells w32time to use a special poll interval which must also be

> Try running this command: 
> NET TIME /SETSNTP:time.windows.com
> That should reset all of the registry values you were messing with.
> Then stop and restart the Windows Time Service.
> Look in the event log. If there are any warnings saying that the time
> server could not be contacted, then you definitely have a networking
> problem. Somehow UDP port 123 is being firewalled or otherwise blocked.
> Have you tried using us.pool.ntp.org instead of time.windows.com?

If w32time queries a real NTP server then you might have to make sure it
sends "client mode" requests to the NTP server instead of "symmetric active
mode" packets since otherwise the NTP server might just discard the request
packets without sending any reply.

Flag 0x8 can be used to force "client mode" requests while flag 0x4 can be
used to force "symmetric active mode" requests, for whatever the latter
might be required. If none of these flags is specified then w32time sends
request packets with a mode which depends on whether it runs on a DC, or

Martin Burnicki

Meinberg Funkuhren
Bad Pyrmont

More information about the questions mailing list