[ntp:questions] Re: w32tm DC error

Heiko Gerstung heiko.gerstung_removeme_ at meinberg.de
Wed Apr 12 06:24:04 UTC 2006


Hej Franz!

Franz schrieb:
> Command "netstat -na" shows [ip-address]:123
> 
> I had installed Meinberg NTP server binary, but it did not work
> neither. Furthermore I just need an ordinary NTP client, which gets a
> synchronized NTP timestamp. I have to implement NTP then in a C++
> program, which should run on ordinary Windows machines.
> 
>> you can use netstat -an |grep "123" from the DOS Command line to get a
>> short list of ntp ports.
> The command netstat -an |grep "123" didn't work on my machine.
> 
> *TRACE & ENVIRONMENT*
> My computer is directly connected to the internet and I tried to trace
> time.windows.com and europe.pool.ntp.org. As you can see in
> http://www.servus-web.de/sweden/thesis/tracert.txt  time.microsoft.com
> timed out, but for europe.pool.ntp.org can be traced, but still the
> result of "w32tm /monitor /computers:europe.pool.ntp.org" is:
> europe.pool.ntp.org [82.67.125.122]:
>     ICMP: 94ms delay.
>     NTP: error ERROR_TIMEOUT - no response from server in 1000ms
> 
> *EVENTVIEWER / EVENTLOG*
> Unfortunately, I missed some error messages in the EventViewer, because
> they have been recently in "Application" instead of "System";
> however, I don't get the reason for the error:
> The description for Event ID ( 17 ) in Source ( W32Time ) cannot be
> found. The local computer may not have the necessary registry
> information or message DLL files to display messages from a remote
> computer. You may be able to use the /AUXSOURCE= flag to retrieve this
> description; see Help and Support for details. The following
> information is part of the event: time.microsoft.com; A socket
> operation was attempted to an unreachable host. (0x80072751); 60.
> 
> *SQL SERVER*
> I read in
> http://www.ntp.org/ntpfaq/NTP-s-trbl-spec.htm#S-TRBL-SPEC-WINNT that MS
> SQL Server might cause problems for NTP, so I stopped SQL Server (but
> did not de-install it).
> 
> *ETHEREAL*
> ethereal only catches outgoing NTP packets, but no incoming NTP
> packets.
> 
> So it seems that NTP packets are sent to the NTP server, but the
> response packet can't reach my computer. Any idea?

OK, short summary:
1. You tried two different applications for time synchronization without 
success
2. You found out with Ethereal that there is no NTP reply coming in

For me it is clear that, if no NTP replies are received by your host, no 
service/application using NTP will ever function properly on your 
system. No matter which software you will try, even if you write your 
own, it will not work until you manage to see NTP packets coming in on 
your ethernet interface.

My suggestions for debugging:
- install NTP on a second PC (lets call it PC B) in your local network 
(using the Meinberg Installer, of course :-))
- configure PC B to use its local clock as a time reference, start the 
NTP service and wait until ntpd shows the asterisk in front of LOCAL(0) 
in the ntpq billboard
- start the NTP service on your PC A and see what happens (with 
Ethereal, capture filter "host ip.of.pc.b and udp port 123")

In order to speed up things

If you receive packets on port 123 from PC B to PC A, you should see 
that PC A will synchronize to PC B after a few minutes. If this happens, 
then NTP works fine on your PC A and you should find out who is blocking 
your incoming NTP packets. Suggestions: Personal Firewall on your PC, 
your Internet router or your ISP..

All other approaches are unnecessary, you need to make sure that you can 
receive NTP packets, period. Good luck :-)

Kind regards,
Heiko


-- 
Meinberg radio clocks: 25 years of accurate time worldwide

MEINBERG Radio Clocks
www.meinberg.de

Stand alone ntp time servers and radio clocks based on GPS, DCF77 and 
IRIG. Rackmount and desktop versions and PCI slot cards.




More information about the questions mailing list