[ntp:questions] Re: D-link and hardcoded ntp servers

Richard B. Gilbert rgilbert88 at comcast.net
Thu Apr 13 21:33:22 UTC 2006

Thomas Tornblom wrote:

> Having read Poul-Hennings open letter, and finding that I had one of
> the affected routers, I quickly reconfigured it to use the swedish ntp
> pool instead, only to find out that this crap product can't handle
> that without crashing :-(
> It can also not use an ntp server on the LAN side, apparently, as all
> my attempts to use one of my internal NTP-servers failed miserably.
> I have now had D-link routers for almost three years, and I am ready
> to declare them to be utter crap, or rather the programmers writing
> code for them.
> My first router was a D-link 804H, which regularly mixed up sessions,
> if I was running multiple sessions of the same type (uucp over
> tcp). After much struggle I got a firmware version that worked.
> When the 804H broke down last summer, I quickly needed a replacement
> while I got the broken one fixed/replaced, and I was handed a D-link
> 624, with 108 Mbps wlan.
> The firmware in that router is the worst piece of crap I have ever
> seen. There is almost nothing you can change in the config on that
> router without the router having to reboot. And if you change almost
> anything from the default, you better watch out so that it won't do
> cyclic restarts.
> After installation it was running fairly well, until I by accident
> noticed some frequent unknown multicast traffic on my lan. I found out
> that this was UPNP, Universal Plug and Play, and that it was the
> router sending out the crap. I found a radio button in the web gui
> that would disable this, so I disabled it. Little did I know then that
> this was the start of multiple daily reboots of the router.
> As I had changed a lot of other things as well, I did not immediately
> connect UPNP and the reboots. I logged a service call with the Swedish
> support, and they gave me several different firmware versions to try,
> including some betas, all to no avail. They even replaced the router,
> and this did nothing to improve things.
> As the crap router can not reliably save and restore the config
> between firmware versions, and the backup is in unreadable binary
> format, you better do all configuration manually after each firmware
> upgrade, and after a while I got bored fixing everything, so I started
> doing the absolute minimum, and noticed that the router would then
> stop restarting. It was then just a matter of changing one thing at a
> time until it started acting up again, which happened to be when I
> disabled UPNP.
> After reporting this, I finally got a firmware where I could reliably
> disable UPNP, and I have been running this firmware up until tonight,
> when I noticed that router has now restarted everyday since I manually
> changed the ntp server. That version could at least get the time from
> the pool servers when it booted, but would crash each time it would do
> its regular syncs.
> I found that new firmware was available, and it specifically mentions
> some ntp fixes, which I assume is to remove gps.dix.dk as the ntp
> server to use. So I downloaded that, and (manually) configured the
> router again, and selected se.pool.ntp.org as the ntp server to
> use. Apparently the router can not handle this as it will not get the
> time at all from that address, with the latest firmware. It will still
> not be able to get the time from my internal server.
> The support line is closed for easter, so I will have to call them
> next week.
> Another, incredibly stupid problem, with this routers firmware is that
> the virtual server settings will not allow you to redirect different
> ports on the wan side to different systems, using the same port, on
> the lan side.
> I found that when I tried to set up two virtual services for ssh,
> where port 22 on the wan side would go to port 22 on system A on the
> lan side, and port 10022 on the wan side would go to port 22 on system
> B on the lan side. That was not allowed, and the support said that
> this was by design! :-( OTOH it would probably have taken at least 10
> firmware respins to get that working.
> The conclusion is that I will never buy a D-link product again. My
> time is worth more to me than having to play with this, which is a
> pity as they are pretty simple to set up.
> Thomas

You get what you pay for.  DLink and Linksys routers are cheap and it 
shows.   The Linksys BEFR81 routers claim DHCP client/server support but 
do not fully implement the protocol as described in RFC 2131.

I'm thinking of getting a Cisco SOHO router in the hope that it will be 
better; it certainly costs enough more that the customer should be 
entitled to expect more.  Does anyone have experience with the Cisco 
model 91 or 731?

More information about the questions mailing list