[ntp:questions] NTP will not ajust time

DavidO davidproc at hotmail.com
Wed Apr 19 21:21:45 UTC 2006


I am running an  NTP cross compile version for a ppc-linux unit (kernel
2.4.21). When I run NTP, it seems that it synchronizes but after a
while starts drifting away until exceeds the tolerance level (500 PPM).
Then, the unit steps time to get in sync but it starts drifting away.
When I run the ntptime command, this is what I got:

ntp_gettime() returns code 5 (ERROR)
  time c7f1285d.30d19000  Wed, Apr 19 2006 21:21:33.190, (.190698),
  maximum error 60365 us, estimated error 0 us
ntp_adjtime() returns code 5 (ERROR)
  modes 0x0 (),
  offset -25082.000 us, frequency 119.825 ppm, interval 4 s,
  maximum error 60365 us, estimated error 0 us,
  status 0x1 (PLL),
  time constant 2, precision 1.000 us, tolerance 512 ppm,
  pps frequency 0.000 ppm, stability 512.000 ppm, jitter 200.000 us,
  intervals 0, jitter exceeded 0, stability exceeded 0, errors 0.

Looks like the adj_time() routine (probably the internal clock is not
working well.
Does somebody what is the reasons for these?
I will appreciate any insight.

	Davido




More information about the questions mailing list