[ntp:questions] The classic "no server suitable for synchronization found" error on my ntpd server.

Mike mikedawg at gmail.com
Thu Apr 27 19:09:29 UTC 2006


I'm trying to figure out why my server is unable to be a "suitable
server for synchronization".  On the ntpd server (will also refer to it
as the server), it has a connection to about 5 different stratum 2 and
stratum 3 servers.  It seems to be running fine, when I execute the
command "ntpq -p" and I pull up a list of those servers, and everything
appears to be normal, offsets avg. around 20 and jitters avg. around
35.

Whenever I try and sync time to my server, from a remote location
(using ntpdate -u <myremotentpdservername> ), I always get the error
"no server suitable for synchronization found".  My server is
firewalled, but it is allowing TCP and UDP connection through port 123
(verified by putting the firewall in debug mode, and seeing the packets
get accepted through the firewall).  I also tried this from a computer
on the same network, again with no firewall.

I have tried from different locations, also not firewalled, and they
can't seem to sync the time with my server, and I can't seem to figure
out why.

I have the following in my ntp.conf file to allow for remote
connections:

  restrict 0.0.0.0 mask 0.0.0.0 nomodify notrap

>From what I can tell, everything appears to be fine with the server.  I
am also unable to sync the time on another computer on the same
network, again, with no firewall interference.

Where can I look for causes of this problem?

Thanks




More information about the questions mailing list