[ntp:questions] Re: Simple ntp setup, but I must be doing something wrong

Richard B. Gilbert rgilbert88 at comcast.net
Fri Aug 25 21:27:46 UTC 2006


Jeff Boyce wrote:
> Greetings -
> 
> Over the last several weeks I have been trying to get the NTP service 
> running properly on my company linux file server, but am not having much 
> success.  My objective is to synchronize my linux server with a 
> secondary time server or one of the ntp pools, then synchronize a 
> handfull of desktop windows systems with the file server.  My reason for 
> doing this is that the timekeeping on the PCs are all over the place, 
> and the server seems to lose anywhere from 1-2 minutes per month.  I 
> don't need anything super accurate, just something that is reasonably 
> close and stays consistent.  I have read everything I can find on 
> setting this up (the link between the PC's and the file server is 
> working properly) and have been following discussions on this list for 
> about a month, but haven't been able to solve it yet.  Below is my 
> config file, the output of ntpq -p and ntpq -pn, and the log messages 
> from the last restart of ntp that matches the configuration file shown 
> below.
> 
> [root at Bison root]# ntpq -p
>     remote           refid      st t when poll reach   delay   offset 
> jitter
> ============================================================================== 
> 
> rainforest.neor 0.0.0.0         16 u    - 1024    0    0.000    0.000 
> 4000.00
> *LOCAL(0)        LOCAL(0)        10 l   21   64  377    0.000    0.000 
> 0.008
> 
> [root at Bison root]# ntpq -pn
>     remote           refid      st t when poll reach   delay   offset 
> jitter
> ============================================================================== 
> 
> 216.176.180.82  0.0.0.0         16 u    - 1024    0    0.000    0.000 
> 4000.00
> *127.127.1.0     127.127.1.0     10 l   53   64  377    0.000    0.000 
> 0.008
> 
> [root at Bison root]# grep --invert-match ^\# /etc/ntp.conf
> restrict 127.0.0.1
> server 216.176.180.82
> server  127.127.1.0     # local clock
> fudge   127.127.1.0 stratum 10
> driftfile /var/lib/ntp/drift
> broadcastdelay  0.008
> 
> /var/log/messages
> Aug 24 08:26:31 bison ntpd[26341]: ntpd exiting on signal 15
> Aug 24 08:26:31 bison ntpd: ntpd shutdown succeeded
> Aug 24 08:26:56 bison ntpdate[27483]: no server suitable for 
> synchronization found
> Aug 24 08:26:56 bison ntpd:  failed
> Aug 24 08:26:56 bison ntpd[27487]: ntpd 4.1.2 at 1.892 Tue Feb 24 06:32:25 
> EST 2004 (1)
> Aug 24 08:26:56 bison ntpd: ntpd startup succeeded
> Aug 24 08:26:56 bison ntpd[27487]: precision = 9 usec
> Aug 24 08:26:56 bison ntpd[27487]: kernel time discipline status 0040
> Aug 24 08:26:56 bison ntpd[27487]: frequency initialized 0.000 from 
> /var/lib/ntp/drift
> Aug 24 08:28:28 bison sshd(pam_unix)[27593]: session opened for user 
> root by (uid=0)
> Aug 24 08:28:51 bison sshd(pam_unix)[27593]: session closed for user root
> Aug 24 08:30:10 bison ntpd[27487]: kernel time discipline status change 41
> Aug 24 08:31:15 bison ntpd[27487]: kernel time discipline status change 1
> 
> I previously thought the problem was firewall related.  I have since 
> turned off the firewall of my linux box, and the firewall application on 
> my DSL router/gateway is set to allow both incoming and outgoing ntp 
> communication. My linux box is a Dell PE 2600 with RHEL 3 fully up to 
> date (U8).  Therefore my current version of NTP is  4.1.2-4.EL3.1.  The 
> secondary time server listed in my config is from the stratum two time 
> server list on ntp.org. This time server is located in the Seattle area 
> (near my location) and is listed as having an open access policy.  It is 
> interesting to note that in my ntpq query this time server provides a 
> listing of stratum 16, which I assume is why ntp is falling back to the 
> local time clock.  

No, nptd is not receiving any response to its queries!  If replies were 
being received, the "reach" field would not be zero.

The server IS responding to my queries (ntpdate -du 216.176.180.82) so 
it is a server and it's working.  You still have a problem with your 
network configuration, firewall or something!  What happens if you try 
to "ping" the server?  That's the basic test for connectivity and, until 
that works, it's quite likely that nothing else will work either.

Your config file looks okay except for the "broadcast delay" statement.
You do not need it because you are not configuring your system as a 
broadcast client.  You don't need the "restrict" statement either.  Get 
it working before you start playing with restrict statements.




More information about the questions mailing list