[ntp:questions] Re: PPS working or not? FreeBSD 5.4

David J Taylor david-taylor at blueyonder.co.not-this-bit.nor-this-part.uk.invalid
Wed Feb 1 07:57:26 UTC 2006


Eugen COCA wrote:
> David,
>
> I have an *identical* configuration. There no need to recompile the
> kernel ! If you have the correct connections (you have) you only need
> to put "enable pps" in the ntpd.conf file.
>
> Please write me on the mail dirrectly for other information.

This is what I had:

#       The GPS receiver on COM1 at 4800 baud
#
#       mode 1 = use $GPRMC statements
#       time1 = trimming offset
#       flag3 1 = enable Kernel PPS discipline
#
server  127.127.20.1    mode 1       prefer
fudge   127.127.20.1    time1 0.000  flag3 1  refid PPS

and recompiling the kernel changed the offset from looking like a typical 
Internet source (few milliseconds accuracy) to a PPS source with a few 
microseconds accuracy.

However, I see that the revision date on the ntp.conf file is /after/ 
recompiling.  I think the only change I made was the refid, but I'm not 
100% sure now.

There was a distinct difference in the output of a "ntpdc -c kern" command 
before and after, as shown towards the end of this page:

  http://www.david-taylor.myby.co.uk/ntp/FreeBSD-GPS-PPS.htm

David 





More information about the questions mailing list